Error parsing proxy URL http://:8080/: Invalid host name.

Asked by tazman34685 on 2009-02-27

Taken From:
Question #44122, asked on 2008-09-04 by Boytim
Error: msttcorefonts subprocess post installation script error exit status 1

I tried:
sudo vim /etc/bash.bashrc and added unset http_proxy and unset ftp_proxy to the end of the file. Then in the same terminal window I ran:
sudo dpkg --configure -a

Same result.......Error parsing proxy URL http://:8080/: Invalid host name.

This is an example of my edited file:

#case "$TERM" in
#xterm*|rxvt*)
# PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME}: ${PWD}\007"'
# ;;
#*)
# ;;
#esac

# enable bash completion in interactive shells
#if [ -f /etc/bash_completion ]; then
# . /etc/bash_completion
#fi

# sudo hint
if [ ! -e $HOME/.sudo_as_admin_successful ]; then
    case " $(groups) " in *\ admin\ *)
    if [ -x /usr/bin/sudo ]; then
        cat <<-EOF
        To run a command as administrator (user "root"), use "sudo <command>".
        See "man sudo_root" for details.

        EOF
    fi
    esac
fi

# if the command-not-found package is installed, use it
if [ -x /usr/lib/command-not-found ]; then
        function command_not_found_handle {
                # check because c-n-f could've been removed in the meantime
                if [ -x /usr/lib/command-not-found ]; then
                   /usr/bin/python /usr/lib/command-not-found -- $1
                   return $?
                else
                   return 127
                fi
        }
fi

unset http_proxy
unset ftp_proxy
~

I also tried using:
unset http_proxy=http://username:<email address hidden>:port/
unset ftp_proxy=http://username:<email address hidden>/

Also:
unset http_proxy=http://:8080/
unset ftp_proxy=http://:8080/

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu msttcorefonts Edit question
Assignee:
No assignee Edit question
Last query:
2009-02-27
Last reply:
2009-03-02
rww (rww) said : #1

It looks like you're experiencing bug 274421. You should be able to fix it by disabling the proxy server setting in gconf with: gconftool --set /system/http_proxy/use_http_proxy --type bool 0

Can you help with this problem?

Provide an answer of your own, or ask tazman34685 for more information if necessary.

To post a message you must log in.