Is mplayer compiled with freetype support?

Asked by Paul Sinnett on 2009-08-23

If I try to play a file with subtitles, they are huge. I want to scale them with the option -subfont-text-scale. But it tells me "Unknown option on the command line"

The docs say this happens if mplayer was compiled without freetype support.

Is there an alternative package with freetype support compiled in?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu mplayer Edit question
Assignee:
No assignee Edit question
Solved by:
Paul Sinnett
Solved:
2009-08-23
Last query:
2009-08-23
Last reply:
2009-08-23
Tom (tom6) said : #1

Hi

I don't know but in MPlayer i right-click in the screen area showing the movie or whatever and choose "Preferences", then click on the "Font" tab and adjust the "text-scale" slider right down to very close to the left-hand side. On my screen the setting shows 4.29 is plenty large enough, more than that is too much.

I hope this helps!
Good luck and regards from
Tom :)

Paul Sinnett (paul-sinnett) said : #2

Hi, thanks for the suggestion. I tried right click but it does nothing for me.

Actually, the reason I wanted it was so that I could embed the subtitles into the video with mencoder. But it turnout out that when I did that, the subtitles were smaller anyway. And now, when I view the original, the subtitles are smaller as well.

So I guess I don't really have an answer to my question. But my immediate problem has resolved itself anyway.

Tom (tom6) said : #3

Brilliant, i think ? ;) :)))
Glad it's all fixed anyway.

I tend to prefer having the subtitles separate as "srt" files so they can be edited or translated using a simple text-editor. I think i installed a few things using a search in synaptic package manager
https://help.ubuntu.com/community/SynapticHowto

Perhaps yu might find a few useful things in there too?
Good luck and regards again from
Tom :)