mplayer dvd://1 -dumpstream -dumpfile uses wrong audio track

Asked by Aaron Whitehouse on 2010-12-19

Hi,

This is mainly for others, as I have figured out the answer myself.

I normally use a little script to rip one vob file for each dvd disc title:
====
#!/bin/bash
if [ $# != 1 ]; then
  echo "Call this with the desired iso file"
  echo "vob-from-iso mydvd.iso"
  exit
fi
TitleLine=$(mplayer dvd://99 -dvd-device $1 | grep "titles")
No_Titles=${TitleLine:10:1}
for ((i=1; i <= No_Titles ; i++))
do
  mplayer dvd://$i -dvd-device $1 -dumpstream -dumpfile $1_$i.vob
done
exit
====

I'm sure that there are more elegant ways, but it works.

For one DVD, the script ripped the incorrect audio track - some English for blind people track that described everything.

What I wanted to know was how to tell mplayer to extract a different audio track.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu mplayer Edit question
Assignee:
No assignee Edit question
Last query:
2010-12-19
Last reply:

Play the file:
$ mplayer dvd://$i -dvd-device $1
(or mplayer dvd://$i -v -dvd-device $1 if you can't find it)
and look for these lines:
audio stream: 0 format: ac3 (5.1) language: en aid: 128.
audio stream: 1 format: ac3 (5.1) language: en aid: 129.

Then add the "-aid" option to mplayer with those aids (128 and 129) and see which is the one you want:
$ mplayer dvd://$i -aid 129 -dvd-device $1

In my case, the end line was:
$ mplayer dvd://1 -aid 128 -dvd-device DVD.iso -dumpstream -dumpfile Title_1.vob

Ha, I spoke too soon.

Turns out that it didn't do what I expected and the aid option was ignored (see Bug 692143).

If anyone knows how to achieve the same result, I would be keen to know.

Can you help with this problem?

Provide an answer of your own, or ask Aaron Whitehouse for more information if necessary.

To post a message you must log in.