How do I disable prescaling in mencoder?

Asked by Mannex on 2010-09-04

I am using mencoder SVN-r1.0~rc3+svn20090426-4.4.3 on Ubuntu 10.04. It is prescaling my video to a different size. Is there any way to disable that? Any help will be greatly appreciated. Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu mplayer Edit question
Assignee:
No assignee Edit question
Solved by:
Mannex
Solved:
2010-09-05
Last query:
2010-09-05
Last reply:
2010-09-04
Mannex (russ-mannex) said : #2

OK, I checked that out, but can't find anything on prescaling. Here's what's happening. I have a video saved on a DVD, and it displays fine, fits my screen, etc. When I use mencoder to make an AVI out of it, it screws up the aspect ratio. I am fairly certain I'm not instructing it to do that. Here's the command I am passing:

mencoder -dvd-device /dev/dvd dvd://1 -ovc lavc -lavcopts vcodec=mpeg4:psnr:mv0:cbp:trell=yes:mbd=2:keyint=125:naq:v4mv:vlelim=-4:vcelim=7:lumi_mask=0.05:dark_mask=0.01:tcplx_mask=0.01:scplx_mask=0.01:vratetol=32000:vbitrate=1200:vpass=1:turbo -slang en -nosound -o /dev/null

and an almost identical line for the second pass, except that vpass=2, there is no turbo specified, and I spacify an output file instead of /dev/null.

Mannex (russ-mannex) said : #3

The lavcopts parameter "autoaspect" for some reason had not worked earlier, but it's working now. Probably a cut and paste error on my part. Anyway, that seems to fix it. Thanks, Sam!

Sam_ (and-sam) said : #4

> When I use mencoder to make an AVI out of it, it screws up the aspect ratio
http://www.mplayerhq.hu/DOCS/HTML/en/aspect.html

There is a slash before -lavcopts.

Mannex (russ-mannex) said : #5

Yes, I knew that. Matter of fact, it's in the one I pasted above. When I mentioned it later, I just didn't put it in the sentence. For brevity, I guess :)