no sound in mplayer

Asked by Albert Zeyer on 2010-08-17

Binary package hint: mplayer

==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
[AO_ALSA] alsa-lib: pcm_hw.c:1293:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Device or resource busy
[AO_ALSA] alsa-lib: pcm_dmix.c:1010:(snd_pcm_dmix_open) unable to open slave
[AO_ALSA] Playback open error: Device or resource busy
Failed to initialize audio driver 'alsa'
AO: [pulse] Init failed: Connection refused
Failed to initialize audio driver 'pulse'
[AO SDL] Samplerate: 48000Hz Channels: Stereo Format s16le
[AO_ALSA] alsa-lib: pcm_hw.c:1293:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Device or resource busy
[AO_ALSA] alsa-lib: pcm_dmix.c:1010:(snd_pcm_dmix_open) unable to open slave
[AO SDL] Unable to open audio: No available audio device
Failed to initialize audio driver 'sdl'
[AO ESD] esd_open_sound failed: Connection timed out
Failed to initialize audio driver 'esd'
Could not open/initialize audio device -> no sound.
Audio: no sound

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: mplayer 2:1.0~rc3+svn20090426-1ubuntu16
ProcVersionSignature: Ubuntu 2.6.32-24.39-generic-pae 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic-pae i686
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/dsp: az 6933 F.... vlc
 /dev/snd/controlC0: az 1661 F.... knotify4
                      az 1700 F.... kmix
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf9ff8000 irq 22'
   Mixer name : 'Realtek ALC1200'
   Components : 'HDA:10ec0888,104382fe,00100101'
   Controls : 40
   Simple ctrls : 22
Date: Tue Aug 17 23:10:18 2010
InstallationMedia: Kubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100427)
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
RelatedPackageVersions:
 libavcodec52 N/A
 libavcodec-extra-52 4:0.5.1-1ubuntu1
SourcePackage: mplayer
UserConf: # Write your default config options here!
dmi.bios.date: 02/23/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 2002
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5Q-PRO
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr2002:bd02/23/2009:svnSystemmanufacturer:pnP5Q-PRO:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5Q-PRO:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: P5Q-PRO
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
system: distro = Ubuntu, architecture = i686, kernel = 2.6.32-24-generic-pae

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu mplayer Edit question
Assignee:
No assignee Edit question
Last query:
2010-10-11
Last reply:
2010-10-11

This question was originally filed as bug #619476.

Albert Zeyer (albertzeyer) said : #1
Reinhard Tartler (siretart) said : #2

The attached user configs indicates a configuration problem:

 - the mplayer output shows that mplayer doesn't try to use pulseaudio at all, but goes via alsa directly
 - the alsa library fails to open the device, most likely because some other application is already holding the device open
 - the mplayer configuration was altered to not use pulseaudio
 - the user alsa configuration contains only comments, but the commented out configuration indicates that the system had at some point two audio cards. This indicates the user has some experience with customizing alsa

I suspect that a pulseaudio daemon is running and blocks the device from being used from other applications. IMO the correct fix is to revert the configuration change and use pulseaudio.

Albert Zeyer (albertzeyer) said : #3

Thanks for your answer.

Yes, I changed mplayer to try ALSA first because Pulseaudio also didn't worked. Pulseaudio doesn't even seem to run for some reason. Why is that?

Yes, I was playing some sound in another application (VLC) via ALSA at the same time. But ALSA should support to output sound via multiple applications at the same time. I always have used it like that in the past.

The changes in ~/.asoundrc are coming from an old setup where I used Gentoo and had multiple sound cards active.

Launchpad Janitor (janitor) said : #4

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Albert Zeyer (albertzeyer) said : #5

I don't really understand? Why can a question expire if there is no answer yet?

Launchpad Janitor (janitor) said : #6

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Albert Zeyer (albertzeyer) said : #7

Hello?

Launchpad Janitor (janitor) said : #8

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Albert Zeyer (albertzeyer) said : #9

Damn, fuck, what is it about this expiring crap? As long as I don't get any answer here, I am still waiting for it. Just waiting 15 days without getting an answer does not help me!

Can you help with this problem?

Provide an answer of your own, or ask Albert Zeyer for more information if necessary.

To post a message you must log in.