No binary mplayer in new package

Asked by iORlas on 2010-03-13

Binary package hint: mplayer

Yesterday i've updated my ubuntu 10.04 with "apt-get upgrade". Today wanted to see one film with mplayer, but ubuntu said "no mplayer installed, install it with cmd ...". Ok, i've tried to install, but apt-get said what mplayer already installed(same for mplayer-nogui).
I've tried to reinstall with purge && install. Same...
But i've tried to see in packages with file-roller. And, oh g-d, i can't see mplayer binary file! gmplayer in, but no mplayer! Ofc, gmplayer throws errors when playing:
mplayer: could not connect to socket
mplayer: No such file or directory

My versions(from installing log):
mplayer (2:1.0~rc3+svn20090426-1ubuntu13)
mplayer-nogui (2:1.0~rc3+svn20090426-1ubuntu14)

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu mplayer Edit question
Assignee:
No assignee Edit question
Last query:
2010-03-13
Last reply:
2010-03-13

This question was originally filed as bug #538353.

Daniel T Chen (crimsun) said : #1

the mplayer binary package now ships /usr/bin/mplayer. Also, see the changelog:

mplayer (2:1.0~rc3+svn20090426-1ubuntu14) lucid; urgency=low
...
  * reorganize binary packages to no longer install the gui version by
    default

ii mplayer 2:1.0~rc3+svn20090426-1ubuntu14 movie player for Unix-like systems
ii mplayer-nogui 2:1.0~rc3+svn20090426-1ubuntu14 movie player for Unix-like systems (transitional package)

iORlas (iorlas) said : #2

No, you dont understand what i mean. I want to use cli mplayer, but binary mplayer not available in package.

>reorganize binary packages to no longer install the gui version by default
I dont need a gui version, i need a cli version(not a gmplayer, i want a mplayer).

iORlas (iorlas) said : #3

Latest package weight - 73kb
mplayer-nogui_1.0~rc3+svn20090426-1ubuntu14_all.deb 12-Mar-2010 19:05 73K

But previous:
mplayer-nogui_1.0~rc3+svn20090426-1ubuntu13_amd64.deb 20-Jan-2010 13:04 2.0M

2mb. It's mplayer binary!
What package now contains it?

Daniel T Chen (crimsun) said : #4

As I pasted above, your packages are not synced with the archive. Please update and upgrade.

iORlas (iorlas) said : #5

But in archive no mplayer binary!
I've trying last 2 hours to update and upgrade, but now news.
See attached log of updating. What i doing wrong?

Daniel T Chen (crimsun) said : #6

Look at the output from apt-cache policy mplayer mplayer-nogui

Reinhard Tartler (siretart) said : #7

the command-not-found data is not updated yet. /usr/bin/mplayer is no shipped by the 'mplayer' package since version 2:1.0~rc3+svn20090426-1ubuntu14. Prior that version, it was in mplayer-nogui.

iORlas (iorlas) said : #8

>the command-not-found data is not updated yet
Really?
iorlas@lastangel:~$ ls /usr/bin/mplayer
ls: cannot access /usr/bin/mplayer: No such file or directory

And i remember, i'm not stupid. I've using find for searching binary, but nothing found.

>Look at the output from apt-cache policy
iorlas@lastangel:~$ apt-cache policy mplayer mplayer-nogui
mplayer:
  Installed: 2:1.0~rc3+svn20090426-1ubuntu13
  Candidate: 2:1.0~rc3+svn20090426-1ubuntu13
  Version table:
 *** 2:1.0~rc3+svn20090426-1ubuntu13 0
        500 http://ru.archive.ubuntu.com lucid/multiverse Packages
        100 /var/lib/dpkg/status
mplayer-nogui:
  Installed: 2:1.0~rc3+svn20090426-1ubuntu14
  Candidate: 2:1.0~rc3+svn20090426-1ubuntu14
  Version table:
 *** 2:1.0~rc3+svn20090426-1ubuntu14 0
        500 http://ru.archive.ubuntu.com lucid/multiverse Packages
        100 /var/lib/dpkg/status

What i doing wrong?

Reinhard Tartler (siretart) said : #9

This report has turned into a support question by now, marking it as such

Reinhard Tartler (siretart) said : #10

install the binary package mplayer with version 2:1.0~rc3+svn20090426-1ubuntu14

Can you help with this problem?

Provide an answer of your own, or ask iORlas for more information if necessary.

To post a message you must log in.