Ubuntu

movemail support in Ubuntu's thunderbird

Asked by Marian Sigler on 2008-03-13

Why is movemail inside the GUI disabled in the ubuntu distribution of thunderbird, although it exists in the original thunderbird?

But the problem with the GUI is not the worst (can be worked around using about:config): On my Computer, I don't have permission to create files in /var/spool/mail. The mozilla distribution of thunderbird showed a nice warning that I don't have the right to create the file. In the ubuntu distribution just nothing happend but it failed silently.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu mozilla-thunderbird Edit question
Assignee:
No assignee Edit question
Solved by:
Marian Sigler
Solved:
2008-03-14
Last query:
2008-03-14
Last reply:
2008-03-14
Bhavani Shankar (bhavi) said : #1

Hello Maix

If you havent figured it out, here are the steps:

1. Edit > Account settings...
2. Select 'Movemail' option in account wizard, hit Next.
3. Set up user information - Your Name 'Jon Doe' <-- displayed name on emails.
4. Set email address to 'your_user_name_here@localhost' <-- no .com / .net / .org suffix.
5. Set 'Outgoing Server' to 'localhost'
6. Account name - I just set this to 'my_user_name@localhost'. You can set it to 'local mail' or 'mail from my machine', etc.
7. Now you will get a summary page that asks you to confirm the following information. It should look like:

Account Name: my_account_name@localhost
Email Address: my_account_name@localhost
Incoming Server Type: MOVEMAIL
Outgoing User Name: my_user_name
Outgoing Server Name (SMTP): localhost

Now all the Thunderbird settings are complete.

When you go to get your mail, you might get the dreaded ""Unable to create lock file /var/mail/navigator.lock. For movemail to work, it is necessary to create lock files in the mail spool directory. On many systems, this is best accomplished by making the spool directory be mode 01777" error. Fun.

To solve this, simply open a terminal and type 'sudo chmod 1777 /var/spool/mail/'
This will set the permissions so that the mail client can access the folder properly. The sudo may or may not be necessary depending on your setup, so you could also just type 'chmod 1777 /var/spool/mail/'.

Secondly it was a bug in thunderbird ubuntu ref:

https://launchpad.net/bugs/148942

and it seems to be fixed in versions 2.0.0.9 and upwards

ref this link on instructions to get the newest thunderbird:

https://help.ubuntu.com/community/ThunderbirdNewVersion

Hope it helps

Bhavani Shankar.

Marian Sigler (maix42) said : #2

Thanks, but that's not what I wanted to know;-) In the original thunderbird it works as you said, but not in Ubuntu's. And I asked why :-)

--maix

Bhavani Shankar (bhavi) said : #3

Hi again Maix..

As I said above it was a bug in thunderbird ubuntu ref:

https://launchpad.net/bugs/148942

and it seems to be fixed in versions 2.0.0.9 and upwards

ref this link on instructions to get the newest thunderbird:

https://help.ubuntu.com/community/ThunderbirdNewVersion

Bhavani Shankar.

Marian Sigler (maix42) said : #4

Ah OK thanks. But I have Firefox 2.0.0.12, and it is not enabled there :-/ But that's something to be reported there.