boot fails, / not available

Asked by Koen on 2011-07-20

i came back home today, and i found that ubuntu can't boot anymore. it did an auto-shutdown yesterday @ 23:30.
it gives me the message during the splash screen 'disk wtih UUID=[insert root UUID here] is not ready or available.' (not an exact quite, thats kinda how i remember it)

i already checked all my partitions for errors, they are clean.

i am still able to access the file-system from live-cd. so i was able to get the contents from /ect/fstab for you:

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda1 during installation
UUID=302d5c95-bfe6-44df-acd1-826ba17d83ef / ext4 errors=remount-ro 0 1
# /home was on /dev/sda6 during installation
UUID=e27abb7a-9d25-409b-bc7d-9865f039bfab /home ext4 defaults,user_xattr 0 2
# /mnt/TeraBackup was on /dev/sdb1 during installation
UUID=66b302dd-d93a-4363-9619-54f8c90817a1 /mnt/TeraBackup ext4 defaults 0 2
# swap was on /dev/sda5 during installation
UUID=4f3a66be-6c03-40bb-95eb-90d7d614a92a none swap sw 0 0

btw: i am using a fully updated version of ubuntu 10,04 LTS

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu mountall Edit question
Assignee:
No assignee Edit question
Solved by:
Koen
Solved:
2011-07-20
Last query:
2011-07-20
Last reply:
2011-07-20

I'd boot to liveCD and fsck the partition, make sure it is healthy

Koen (gorgabal) said : #2

never mind, just found out that my boot flag was disabled. enabling it on my root partition using gparted solved the problem for me.