Is Monodevelop 2.x planned for inclusion in Jaunty?

Asked by Chris Morgan on 2009-01-29

The version of Monodevelop in Intrepid and currently in Jaunty is old compared to the latest release of Monodevelop. Is Monodevelop 2.x planned for inclusion in Jaunty?

Thanks,
Chris

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu monodevelop Edit question
Assignee:
No assignee Edit question
Solved by:
Chris Morgan
Solved:
2009-01-29
Last query:
2009-01-29
Last reply:
2009-01-29
nhasian (nhasian) said : #1

Hello cmorgan,

looks like the Monodevelop 1.0 in the repositories is the latest stable version. i see on their website they have 2.0 but its still marked as unstable.

Chris Morgan (chmorgan) said : #2

It may not be stable but the 1.x verions are really old at this point so even an unstable newer version would be better than the older version. The version in Intrepid prevents the use of some .net framework 3.5 features like HashSet for some reason.

So what's the answer?
It wil be or not in Jaunty's Official repos?

Chris Morgan (chmorgan) said : #4

I really hope the latest alpha or beta is picked up since the 1.0 version included is so old. The monodevelop plan is to release a stable version at the end of March I believe. Is it possible to pick up the alpha/beta now and then update the Jaunty package to the stable version as a 'bugfix' when that is released?

Unfortunately the Features Freeze will be very soon, on February 19th...
I think there's few chaces to view Monodevelop 2 included in Offical Repos..

Matthew Paul Thomas (mpt) said : #6

Monodevelop 2.0 appeared in Jaunty a few minutes ago.
<https://launchpad.net/ubuntu/jaunty/+source/monodevelop/2.0+dfsg-1~ubuntu1>

Boas Novas (djalma-silva-jr) said : #7

what about de mono 2.4 version in ubuntu 9.04?

Matthew Paul Thomas (mpt) said : #8

Boas, Ubuntu 9.04 was released over a month ago.