Unable to run windows forms application "no implementation for interface method Atk.TableImplementor::get_SelectedColumns()" Error occured.

Asked by PioneerAxon on 2011-06-21

While I tried to run an application created on windows forms, on visual studio, I got the weired error.

no implementation for interface method Atk.TableImplementor::get_SelectedColumns() in class UiaAtkBridge.Table
METHOD .ctor(System.Windows.Automation.Provider.IRawElementProviderFragment)
METHOD RaiseAutomationEvent(System.Windows.Automation.AutomationEvent,System.Windows.Automation.AutomationEventArgs)
METHOD RaiseStructureChangedEvent(object,System.Windows.Automation.StructureChangedEventArgs)
METHOD RaiseAutomationPropertyChangedEvent(System.Windows.Automation.AutomationPropertyChangedEventArgs)
METHOD RefAt(int,int)
METHOD GetIndexAt(int,int)
METHOD GetColumnAtIndex(int)
METHOD GetRowAtIndex(int)
METHOD get_NColumns()
METHOD get_NRows()
METHOD GetColumnExtentAt(int,int)
METHOD GetRowExtentAt(int,int)
METHOD get_Caption()
METHOD set_Caption(Atk.Object)
METHOD GetColumnDescription(int)
METHOD GetColumnHeader(int)
METHOD GetRowDescription(int)
METHOD GetRowHeader(int)
METHOD get_Summary()
METHOD set_Summary(Atk.Object)
METHOD SetColumnDescription(int,string)
METHOD SetColumnHeader(int,Atk.Object)
METHOD SetRowDescription(int,string)
METHOD SetRowHeader(int,Atk.Object)
METHOD GetSelectedColumns(int&)
METHOD GetSelectedColumns(int[]&)
METHOD GetSelectedRows(int&)
METHOD GetSelectedRows(int[]&)
METHOD IsColumnSelected(int)
METHOD IsRowSelected(int)
METHOD IsSelected(int,int)
METHOD AddRowSelection(int)
METHOD RemoveRowSelection(int)
METHOD AddColumnSelection(int)
METHOD RemoveColumnSelection(int)
METHOD EmitRowReorderingSignal()
METHOD OnRefStateSet()

[Lots of call stack trace lines]....

I was able to run it before. I don't know what went wrong, I installed many packages afterwards. I checked again & now it gives the above error.

I think it is some package installed after last successful run, but can't figure out what is wrong.
Please help me run my application again..

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu mono Edit question
Assignee:
No assignee Edit question
Solved by:
PioneerAxon
Solved:
2011-06-21
Last query:
2011-06-21
Last reply:
PioneerAxon (arth-svnit) said : #1

Sorry to bother you at all.
While searching on web, I just found a solution at
Just wanted to post it so anyone with same problem can solve the problem.
Solution found at:
http://sourceforge.net/projects/keepass/forums/forum/329221/topic/3888372

seemed to have the problem with package libmono-uia-winforms1.0-cil
Uninstalling it solved the problem.