Cannot make environment-module package work on ubuntu trusty

Asked by Lemieux


My OS is Ubuntu 14.04. I installed the environment-module binaries (version 3.2.10) with apt-get.
Typing "module" in a terminal leads to (in french):

module : commande introuvable

The "module" command is not recognized, nor the "module list" command,... etc.

I checked if some of the files of the package exist:

ll -t /etc/csh/login.d/modules
-rw-r--r-- 1 root root 455 déc. 12 2013 /etc/csh/login.d/modules

They do indeed (at least the one I checked for).

Am-I doing something wrong? Can you please help me to make it work?


Question information

English Edit question
Ubuntu modules Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Lemieux (blemieux) said :

Hi again,

I have just compiled the module-3.2.10 from source (see link using the gnu compilers on my OS Ubuntu 14.04. And it worked. I guess it might work with the binaries two but I still do not understand how.

If ever it can help, here is the way I proceed:

- I add to install first tcl8.6-dev (since the configure script was complaining about file missing).

- Since I got an error message at the make step regarding 'errorLine' stuff (see bug report here, I ran the configure script with CPP flag set this way CPPFLAGS="-DUSE_INTERP_ERRORLINE":

CPPFLAGS="-DUSE_INTERP_ERRORLINE" ./configure --prefix=/opt/module/module-3.2.10 --with-module-path=~/modules

then "make", and "make install" worked properly.

- Under my home, I ran the script:


it automatically modifies .bashrc, .profile (or .cshrc...) so that it runs the following module command:

$PREFIX/Modules/$MODULE_VERSION/bin/modulecmd $modules_shell


$PREFIX is in my case /opt/module/module-3.2.10 (see the argument of --prefix of the configure script),
$module_shell being set on the right shell automatically in the .bashrc,
$MODULE_VERSION is set to 3.2.10 (I guess during install).

- then typing "module" at the prompt worked.

Cheers, B.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
Did you also try looking at the package you installed and reading it's man page

Revision history for this message
actionparsnip (andrew-woodhead666) said :
Revision history for this message
actionparsnip (andrew-woodhead666) said :

The last link I gave shows this:
modulecmd.tcl version 1.144 released

So no new release in nearly 3 years. you really want to use this?

Have you contacted the developers?

Revision history for this message
Lemieux (blemieux) said :

Thank you for answers. I did visit this link:

Sorry to bother with this pb. I think my on built will do the job. I just coudn't succeed with Ubuntu binaries.