Modem Manager Locks Dual FTDI Serial Ports

Asked by Ash Charles on 2012-12-27

I'm trying to connect serial console to an embedded device and but I'm not able to connect for the first 36 seconds after connection as modem-manager has locked the /dev/ttyUSB1 file (as shown by '$ sudo lsof /dev/ttyUSB1'). By blacklisting the USB ID (0403:6010) of the device in the '77-mm-usb-devices-blacklist.rhles' udev rule, I can immediately access the device.

Much like the commonly used single FTDI USB-serial converter chip (USD ID 0403:6001) that is blacklisted in this file "77-mm-usb-device-blacklist.rules", I think the dual version (USB ID 0403:6010) chould also be added as it is commonly used in JTAG debugged boards and embedded devices.

I would like to submit a patch but I'm not quite sure where to send it....sorry :(.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu modemmanager Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-12-27
Last query:
2012-12-27
Last reply:
2012-12-27
N1ck 7h0m4d4k15 (nicktux) said : #1

Close this question (solved) and open a bug report.

There you can submit patches.. etc.. to speak with the developers.

Thank you.

Run:

ubuntu-bug modemmanager

And report the bug :). The patch will then be included by default and more things will work out of the box. Great work!

Ash Charles (ashcharles) said : #3

Thanks actionparsnip, that solved my question.

Ash Charles (ashcharles) said : #4

linked bug Bug #1094138