Will 4.5.9 for zesty be back ported to xenial?

Asked by David Oberst on 2016-12-06

Will the update to mod-wsgi 4.5.9 showing for zesty eventually be included in xenial-updates for the LTS, and if so is there any rough idea of when?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu mod-wsgi Edit question
Assignee:
No assignee Edit question
Last query:
2016-12-06
Last reply:
2016-12-06
Manfred Hampl (m-hampl) said : #1

I suggest that you create a bug report, stating the improvements and/or bug fixes between the versions.
If the changes are important enough, then there might be a backport to the older release(s).

There might be also other options:
Maybe the version for zesty can also be installed on a xenial system without any problems with dependencies
You could try compiling the 4.5.9 version on your xenial system
You may find a PPA with such version
You could create your own PPA with such version

David Oberst (ykdvd) said : #2

I'll look into compiling from source, or if anyone else maintains a current package. But we are upgrading an ancient box (which has mod-wsgi 3.3) and considering Xenial or Debian jessie/stretch, and it would be nice not to have to dig into the details for this, given it is an Apache module and not a vanilla app or something.

I realize this is mainly a pass-through from the Debian package, which seems to have been somewhat dormant, but the mod-wsgi 4.3 that was included in Xenial dates back to 2014 - version 4.4.22 was available Nov/2015. I'll have to go through the release notes anyway to see what fixes/features have come along since the ancient 3.3 version we've been using, and I can file a bug report to suggest a xenial backport if that will be helpful. But for future LTS releases it might be good to see if something fairly current can be included.

Out of curiosity, the launchpad overview page here for mod-wsgi shows "PyLucid" as "upstream" for mod-wsgi. PyLucid seems to be a CMS system, and is presumably a consumer of mod-wsgi, not an upstream source or owner. Is this a glitch?

Manfred Hampl (m-hampl) said : #3

1. I have removed the upstream link to PyLucid (anyone could have done that).

2. Checking the dependencies of the 4.5.9-1 package in zesty
 apache2-api-20120211
 apache2-bin (>= 2.4.16)
 libc6 (>= 2.14)
 libpython2.7 (>= 2.7)
 python (>= 2.7)
 python (<< 2.8)
it seems to me that it would be possible to do a manual installation of that package on a xenial system.

Can you help with this problem?

Provide an answer of your own, or ask David Oberst for more information if necessary.

To post a message you must log in.