libapache2-mod-auth-mysql : error with special characters in users passwords

Asked by Guillaume on 2012-08-09

Hello,

I'm running Ubuntu server 10.04 AMD64 with libapache2-mod-auth-mysql (4.3.9-12ubuntu1).
Encryption is set to PHP_MD5.

Accounts passwors are md5 encoded using PHP et stored in a mysql database (5.1.63-0ubuntu0.10.04.1).
The database is in UTF-8 (utf8_general_ci) so the mysql connection.

If, a password doesn't contain any special caracter (like an accentued one), auth will work fine.
It it contain one or more, it doesn't work (auth is refused).

I tested the auth using PHP and MD5, but it seems that auth-mysql PHP_MD either doesn't like special chars and/or utf-8.

Is there a way to fix it ?

Regards,

Guillaume

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu mod-auth-mysql Edit question
Assignee:
No assignee Edit question
Last query:
2012-08-31
Last reply:
2012-08-29
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Guillaume (e1msih) said : #2

Message translated from french to english.

I suggest you report a bug. Does it happen in Precise?

Guillaume (e1msih) said : #4

I'll do it tomorrow.
I can't upgrade to precise yet on this server so i don't know if it's the case.

Guillaume (e1msih) said : #5

Bug submitted.

Is it ok in Quantal, just to test.....

You can make a virtual machine

Guillaume (e1msih) said : #8

I'm planning to create one but i'm busy for a few days.
I think it will be ok this friday.

Guillaume (e1msih) said : #9

Ok, it's not ubuntu/server related.
With Chrome, the htaccess auth will work just fine with accentued characters in the password field.
With Firefox (14 and superior) it won't work.
With IE9, it won't work either.

What could be causing this problem ?

Guillaume (e1msih) said : #10

And if I specify the auth parameter in the url, like http://user:passwod@ip it will work regardless the browser used.

Can you help with this problem?

Provide an answer of your own, or ask Guillaume for more information if necessary.

To post a message you must log in.