Unable to open /dev/ttyUSB0

Asked by Philip Boucherat on 2011-09-12

I have got a Prolific-based USB to serial converter which I have been trying to use on Ubuntu 10.04 and 11.04 using VMWare 6.5.5 on Windows 7, however, in both 10.04 and 11.04, if I try to use minicom with /dev/ttyUSB0 I always get the same error : "minicom: cannot open /dev/ttyUSB0: No such file or directory".

/dev/ttyUSB0 does exist :

crw-rw---- 1 root dialout 188, 0 2011-09-12 01:37 /dev/ttyUSB0

And the kernel messages show that the device has been attached to ttyUSB0 :

[ 1230.127294] USB Serial deregistering driver pl2303
[ 1230.129250] usbcore: deregistering interface driver usbserial_generic
[ 1230.129568] USB Serial deregistering driver generic
[ 1230.129863] usbcore: deregistering interface driver usbserial
[ 1237.939899] usbcore: registered new interface driver usbserial
[ 1237.940743] USB Serial support registered for generic
[ 1237.942031] usbcore: registered new interface driver usbserial_generic
[ 1237.942035] usbserial: USB Serial Driver core
[ 1237.946838] USB Serial support registered for pl2303
[ 1237.947265] pl2303 2-1:1.0: pl2303 converter detected
[ 1248.206356] usb 2-1: pl2303 converter now attached to ttyUSB0
[ 1248.206383] usbcore: registered new interface driver pl2303
[ 1248.206386] pl2303: Prolific PL2303 USB to serial adaptor driver

And lsusb gives this :

imgdev@ubuntu:~$ lsusb
Bus 002 Device 003: ID 0e0f:0002 VMware, Inc. Virtual USB Hub
Bus 002 Device 002: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

So it all looks ok to me. On 11.04 it did work briefly but then stopped working for no apparent reason. I tried a different USB to serial converter but that had the same problem. There is no problem using this USB to serial converter if I use it from a Fedora VM. So I'm wondering if the problem is with Ubuntu or with the VMWare drivers.

In any case, a fix for this would be much appreciated.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu minicom Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
Last query:
Last reply:
Revision history for this message
Best marcobra (Marco Braida) (marcobra) said :
#1

Please be sure your user have the permission to use device...

open a terminal and type:

users-admin

then go to advance-settings of your user...

Revision history for this message
Philip Boucherat (philb32) said :
#2

Well ok, I just did "sudo minicom" and it started working so maybe you are right about the permissions! I tried users-admin and enabled access to all device for the default user and that didn't work even though the account type of the default user is Administrator.