Problem in setting up serial console (minicom client)

Asked by Gaurav Aggarwal on 2010-12-03

I am trying to setup a serial console between two ubuntu machines. Basically, I am trying to follow the below mentioned article for the same, but with no luck so far.

https://help.ubuntu.com/community/SerialConsoleHowto

I am pretty sure that my server side configurations are done properly since I am getting the login prompt when using windows machine (hyperterminal) as client to connect any of these machines. But, when I am trying to connect to the same using another Ubuntu machine (via minicom) as the client, I am not getting the login prompt on the serial console.

Since setup is working fine with the windows (hyperterminal), I guess this has something to do with my minicom setting for this problem. Any information would be great, how can I troubleshoot the same.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu minicom Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Gaurav Aggarwal (gaurav.aggarwal) said :
#1

Here is some more update. By default, /dev/ttyS0 is owned by root:root in my machine. So, once I changed it to root:dialout and add the user to dialout group, I start getting messages from the other computer. So, now it looks like this:

$ ls -al /dev/ttyS*
crw------- 1 root root 4, 64 2010-12-03 14:44 /dev/ttyS0
crw-rw---- 1 root dialout 4, 65 2010-12-03 13:42 /dev/ttyS1
crw-rw---- 1 root dialout 4, 66 2010-12-03 13:42 /dev/ttyS2
crw-rw---- 1 root dialout 4, 67 2010-12-03 13:42 /dev/ttyS3

$ chown root:dialout /dev/ttyS0
$ ls -al /dev/ttyS*
crw------- 1 root dialout 4, 64 2010-12-03 14:44 /dev/ttyS0
crw-rw---- 1 root dialout 4, 65 2010-12-03 13:42 /dev/ttyS1
crw-rw---- 1 root dialout 4, 66 2010-12-03 13:42 /dev/ttyS2
crw-rw---- 1 root dialout 4, 67 2010-12-03 13:42 /dev/ttyS3

Note, that I am running all these commands (including running minicom) as root (yeah, I know about the security concern, but currently my priority is to make this setup working).

So, after changing the group of /dev/ttyS0, I start getting the messages from other machine but still I am not able to write anything into it i.e. on getting the console prompt, I am not able to enter any input like username/password. Seems like minicom is not accepting any input from my keyboard.

Also, note that if from the other machine, I typed the following command:
$ echo "Assasa" > /dev/ttyS0 (from machine 2)
I can see the output Assasa on machine 1 (one in which minicom is running).

Please let me know how can I proceed further.

Revision history for this message
Gaurav Aggarwal (gaurav.aggarwal) said :
#2

Ok, I think now I am getting close to it. Now, I tried to use the similar setting for the minicom on a machine running Cent OS, and I am able to do it perfectly. Minicom is working and I am able to access the other machine without any problems. To me, seems like this is a bug from Ubuntu perspective.
Let me know if I am missing something in the above setting (since even after more than 3 days of initial posting, there are no responses) or else I am planning to open a bug against the same.

Revision history for this message
deep (deepa) said :
#3

Hi Gurvesh ,

I also had faced the same issue on my newly installed ubuntu machine..I changes following settings on minicom and it worked.
Please try out and see it works
minicom -s

F - Hardware Flow Control : No

Revision history for this message
Vinaya Sagar (vinayasag) said :
#4

Thanks deepa. minicom started taking input from keyboard once I made
Hardware Flow Control: No

Revision history for this message
Mantri Yogesh (ykmantri) said :
#5

Thanks deep, you saved my time..

Can you help with this problem?

Provide an answer of your own, or ask Gaurav Aggarwal for more information if necessary.

To post a message you must log in.