Trouble installing minicom

Asked by suspect76 on 2010-09-16

I installed minicom and when I tried running it from the command line i get the following error message and I do not know how to fix it. any help will be greatly appreciated. I am trying to use minicom to configure a Cisco switch. If you have done this before any information you can share with me will be greatly appreciated.

*********************************************************************************
:~$ minicom -c on
minicom: cannot open /dev/tty8: Permission denied
*********************************************************************************

Distributor ID: Ubuntu
Description: Ubuntu 10.04.1 LTS
Release: 10.04
Codename: lucid
kernel: 2.6.32-25-generic
 x86_64 GNU/Linux

I used the instructions located at this link

http://www.cyberciti.biz/tips/connect-soekris-single-board-computer-using-minicom.html

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu minicom Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
Last query:
Last reply:
Revision history for this message
Best marcobra (Marco Braida) (marcobra) said :
#1

please check if your user have all permissions
please open the menu System→Administration→User and groups
and check the permissions of your user please give all permissions using the
"Advanced settings" go to "Users Priviledges" and set all permissions

if this doesn't solve please open a terminal and type:

ls -la /dev/tty8

copy and paste result here

Revision history for this message
suspect76 (gareth-suspect76) said :
#2

hi, thanks for replying to me.......I do have all the permissions enabled but I still got the error message but when I entered the command you gave me i released that it look like only root had access so i entered sudo in front of command and I was able to run it.

running your command gave me this.

:~$ ls -la /dev/tty8
crw--w---- 1 root tty 4, 8 2010-09-16 21:51 /dev/tty8

so I then ran

:~$ sudo minicom -c on

And it came right up...thank you very much for the information which led to me knowing what to do...thanks again.

Revision history for this message
suspect76 (gareth-suspect76) said :
#3

Thanks marcobra (Marco Braida), that solved my question.