permission denied

Asked by Roger Davis on 2013-02-26

How do I fix this?

roger@roger-desktop:~$ mgetty
cannot open logfile /var/log/mgetty/mg_unknown.log: Permission denied
cannot log to /dev/console, disable logging: Permission denied
roger@roger-desktop:~$

Ubuntu 12.04, 64 bit

US Robotics modem, Linux approved, model 5610-c http://www.usr.com/support/product-template.asp?prod=5610c

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu mgetty Edit question
Assignee:
No assignee Edit question
Last query:
2014-03-11
Last reply:
2014-03-11
Thomas Kr├╝ger (thkrueger) said : #1

You have to start service daemon with the appropriate command:

sudo service service_name start

service_name should be something like mgetty. You can see all options by typing "sudo service " (with space at the end) and hitting [Tab] twice.

Try:

sudo mgetty

Roger Davis (rogerdavis-d) said : #3

Neither of the above works.
=======================================
You have to start service daemon with the appropriate command:

sudo service service_name start

service_name should be something like mgetty. You can see all options by typing "sudo service " (with space at the end) and hitting [Tab] twice.

--------------

mgetty is not one of the services shown in the list after Tab twice, giving me "mgetty: unrecognized service"

=========================

sudo mgetty has no response whatever, just returning me to the prompt, whereas mgetty alone gets the response shown above.

Manfred Hampl (m-hampl) said : #4

As far as I know, processes like mgetty (or getty) need a device as parameter.
And the mgetty process should be automatically started by init/upstart.
Where did you get an instruction to use mgetty manually from a command line?

What is the output of
ls -l /etc/init/tty*.conf
ps ax | grep tty

Roger Davis (rogerdavis-d) said : #5

roger@roger-desktop:~$ ls -l /etc/init/tty*.conf
-rw-r--r-- 1 root root 348 Apr 16 2012 /etc/init/tty1.conf
-rw-r--r-- 1 root root 333 Apr 16 2012 /etc/init/tty2.conf
-rw-r--r-- 1 root root 333 Apr 16 2012 /etc/init/tty3.conf
-rw-r--r-- 1 root root 333 Apr 16 2012 /etc/init/tty4.conf
-rw-r--r-- 1 root root 232 Apr 16 2012 /etc/init/tty5.conf
-rw-r--r-- 1 root root 232 Apr 16 2012 /etc/init/tty6.conf
roger@roger-desktop:~$ ps ax | grep tty
 1249 tty4 Ss+ 0:00 /sbin/getty -8 38400 tty4
 1256 tty5 Ss+ 0:00 /sbin/getty -8 38400 tty5
 1273 tty2 Ss+ 0:00 /sbin/getty -8 38400 tty2
 1278 tty3 Ss+ 0:00 /sbin/getty -8 38400 tty3
 1285 tty6 Ss+ 0:00 /sbin/getty -8 38400 tty6
 1681 tty7 Ss+ 21:52 /usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
 1771 tty1 Ss+ 0:00 /sbin/getty -8 38400 tty1
 5127 pts/0 S+ 0:00 grep --color=auto tty

This all ties into https://bugs.launchpad.net/ubuntu/+bug/1087519

Manfred Hampl (m-hampl) said : #6

The difference between "mgetty" and "sudo mgetty" seems to me that without sudo you lack the permission to create the log file in /var/log/mgetty/ and mgetty aborts immediately with the error message. With sudo in front you have the right to create the log file there, and it seems to me that mgetty runs and terminates successfully in such case. Can you check whether there are log files created in that directory? What is the contents?

Still I doubt that running mgetty in a terminal would provide any help with your problem. Browsing through the bug report that you mentioned above and comparing it with the output above, I now do not see any ttyS4 device on your system any more. So the modem seems not identified at all.

Is there anything in the system logs that indicates whether the system recognized the modem at all?

Can you help with this problem?

Provide an answer of your own, or ask Roger Davis for more information if necessary.

To post a message you must log in.