In Ubuntu 10.04 the page minimize "-" closes the page instead of minimizing it.

Asked by David Mawdsley on 2011-07-16

My minimize option started causing the close of the page rather than minimizing it to the bottom panel. So the minimize was working like the "x". Because I normally use the minimize a lot, and it wasn't working, I've had to go to gconf-editor to change the apps>metacity>general>button_layout entry for the minimize, maximize, close options for pages so it now reads just "menu:maximize,close".

It's a nuisance to use it this way, but I kept clicking on the minimize and losing the page I was using by mistake sometimes after a lot of work. Hopefully someone has a work-around that will help me put things back to normal as "menu:minimize,maximize,close" which I use to have. When I put that format back, the minimize problem returns.

The minimize should do just what it's designed to do and not close my documents! A few days prior to this change of behavior I deleted the bottom panel by mistake and then put it back with icons of desktop, trash and 6 workspaces. I think this happening may have affected the minimize control in some way. Help on this would be appreciated.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu metacity Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2011-07-17
Last query:
2011-07-17
Last reply:
2011-07-16

Change:

menu:maximize,close

To:

menu:maximize,minimize,close

Does it help

David Mawdsley (dm-madmod) said : #2

Unfortunately, no. The incorrect behavior on the "-" option returns. Maximize toggles okay and the close option works okay also.

Ok try:

close,minimize,maximize:

That's what mine says.

David Mawdsley (dm-madmod) said : #4

That doesn't work either. It seems that whenever "minimize" is in the list it's action is to "close." Even right-mouse on the bar containing the buttons and choosing "Minimize" causes the "close" action to occur. So I'm fairly certain that the button_layout config in the metacity general listing isn't the reason for the wrong action. The buttons resort as wanted on the bar just fine in the button_layout setting.

Somewhere in another configuration setting there has to be a way to change the action for "minimize" as it's calling the routine to "close" instead. I think I'm going to have to learn to live with using only the "maximize" and "close" buttons on the bar.

I had an update today with Update Manager that brought in a new kernel. After rebooting the computer the minimize problem isn't changed, so I figure it's not a kernel issue. If figure that something's busted in my Ubuntu 10.04. I'm not willing to reinstall Ubuntu 10.04 as I have too many settings involving ssh, mySQL, apache, samba, etc. that I'm not prepared to lose.

Actionparsnip: if you think of anything else somewhat later, please write. My e-mail is <email address hidden>. Thanks.

David Mawdsley (dm-madmod) said : #5

I think I've found a fix for my problem.
1. Delete the bottom panel.
2. Right-mouse on the top panel and choose "New Panel."
3. On the bottom panel now right-mouse and choose "Add to Panel."
4. Click on "Trash" and then the Add button.
5. Click on "Workspace Switcher" and then the Add button.
6. Click on "Window List."
At this point the metacity format can be "menu:minimize,maximize,close" and the minimize button now works as it should. The "Window List" seems to activate the buttons in the ways they should normally work.
Whew!

David Mawdsley (dm-madmod) said : #6

Thanks actionparsnip, that solved my question.