top bar missing from each window

Asked by Neil on 2011-05-01

Hi
Just updated to 11.04 but have 1 little problem the top bar on the windows is missing as you could understand this is a bit of a problem.
I used this command in terminal metacity --replace
I have the bar while terminal is open but close it and it gone, and rebooting not helping same problem.
I went to Additional Drivers in Admin it is saying that the driver is active but not currently in use. is this the problem?

Can some please help me out
Thanks
Neil

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu metacity Edit question
Assignee:
No assignee Edit question
Solved by:
Neil
Solved:
2011-05-08
Last query:
2011-05-08
Last reply:
2011-05-02
Neil (goofandfroggie) said : #1

Found 1 problem
If i log in using the "Ubuntu" Desktop (from login) all is good
but if "classic Ubuntu" there is the problem no top bar.
If I use the "classic without effects" I have bar but on effects

I want not to use unity sorry to say it is not very good. don't like it one bit.
I would like classic with all the trimmings classic with effects

Can I get into "Ubuntu" install unity?

Can you give the output of:

sudo lshw -C display; lsb_release -a

Thanks

Neil (goofandfroggie) said : #3

 *-display
       description: VGA compatible controller
       product: G94 [GeForce 9600 GT]
       vendor: nVidia Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:16 memory:fd000000-fdffffff memory:d0000000-dfffffff memory:fa000000-fbffffff ioport:cc00(size=128) memory:fc000000-fc07ffff
LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty

Yeah thought it'd be an nvidia.

If you run:

sudo nvidia-xconfig; gksudo gedit /etc/X11/xorg.conf

In the screen section, add:

Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"

Save the new file and restart X, or reboot the system, should be ok

Neil (goofandfroggie) said : #5

Hi
did that so it now reads as
Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "AddARGBVisuals" "True"
    Option "AddARGBGLXVisuals" "True"
    SubSection "Display"
        Depth 24
    EndSubSection

but still no good classic still not right and driver still not in use

Neil (goofandfroggie) said : #6

hmm interesting
I just found compiz turned a few things on ie desktop cube
and now no top bar in the "Ubuntu" setting

Neil (goofandfroggie) said : #7

getting worse I rebooted now there is no tool bars top,bottom or side. Alf+F2 not working so I can't restart tool bars

ok then boot to root recovery mode and run:

mv /etc/X11/xorg.conf /etc/X11/xorg.conf_old; reboot

and you will be back where you were

Neil (goofandfroggie) said : #9

Hi
Did that
I dropped to shell is that right? never used that be for.
them typed in the commands you gave.
but still nothing I do have the awn bar working so I can get google chrome . and I can get to computer and a folder on the desktop

Neil

Are you back to where you started though?

delance (olivier-delance) said : #11

Hello actionparsnip. I have also this issue (no, I'm not answering this question!).
I have an NVidia card. I already had issues with 10.10, which needed usage of "metacity -replace".
I have no upper and lower bar. Icons on desktop were kept.

delance (olivier-delance) said : #12

  *-display
       description: VGA compatible controller
       product: G94 [GeForce 9600 GS]
       vendor: nVidia Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:16 memory:ec000000-ecffffff memory:d0000000-dfffffff memory:ea000000-ebffffff ioport:bf00(size=128) memory:ed000000-ed07ffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty

Neil (goofandfroggie) said : #13

Hi
No not back to were I started.
 (G'day delance not that I wish you problems but it is nice to know I'm not the only one lol)
the command makes no difference. I may have to reinstall. but will keep on trying
Would like to use 11.04. but if problem is still there will go back to 10.10.
I would like to upgrade but I must say without Unity. not easy to use and very messy and Ugly!!!! that tool bar!!!!

Thanks for your help so far. maybe with your help can get it up and running.
Neil

in saying top bar do you mean were the exit and minimize buttons are

Neil (goofandfroggie) said : #15

yes that is the one I'm talking about

Been playing around, have found that if I use the"Ubuntu" setting ( from login screen) I have all of the problems no top tool bar or window bars (minimise button etc)
In the "classic" no top tool bar but I have the window bars.
In the "Classic' ( without Effects ) It is all there, all bars, working but no effects of course.

But if still don't have nvidia drivers working properly , there are saying activated but not in use, though having said that they are working because the fan on my graphic card is not running flat out as it would if there were no driver at all.
I tried the older driver 175 I think it is but still no help.

So it seem that nvidia is the problem
Thanks
Neil

I have the same problem too. No tool bars, just the static windows. Luckly I realized that if you login into Ubuntu Classic is the remedy for the problem... but i really want to use Unity. Is there any way you can activate those windows again?
@actionparsnip I have a ATI Radeon card but I don't think it's the source of the problem, because when I first upgraded to Natty it was all perfect and clean. When I activated the desktop cube it triggered so many "conflicts" that I just put enable to all. At the worst case, is there any way to go back?

delance (olivier-delance) said : #17

Hello, I solved the problem but I don't know how exactly!
I have NVidia card. The proprietary driver was not running. Due to issues in 10.10 of same kind, I had in System->Preferences->Startup Application an launcher which run "metacity --replace".

At boot, if I chose "Recovery" in Grub menu, and then "sanfailsafe X", I had the top bar.
So:
1) I installed and activated proprierary driver n° 173.
2) I removed the launcher with "metacity --replace".
3) System->Administration->Login Window: I chose "Ubuntu classic without effects"
And it works.

I hope I didn't forget the good action!

Neil (goofandfroggie) said : #18

Yea I can get no effects running but all the effect I have set wont work of course.
I will reinstall on other HDD maybe ok will let you know but wont be for a few days
Neil

Neil (goofandfroggie) said : #19

well I tied reinstalling and found that seems to be a problem with compiz. both 32&64bit same problems exist.
I Installed Ubuntu Tweek. all good there, I install compiz from there, still all good, BUT as soon as I tried to set the cub ( rotate etc) in compiz it all goes belly up. I lose things. tool bar and the minimise bar, as I have mentioned above. (other settings still seem ok ie wobbly windows,.
Having tried the different settings (Ubuntu, classic and no effect) different problem in different settings but for no effect all seem to be there but a bit boring just like using XP lol

Having said all that I still have the same problem with my graphics (nVidia) its still saying not in use. but I it seem to be working ok, very strange indeed.
I have not tried 3rd the graphic setting of experimental (sorry not the right name forgot what it is) but I will try that very soon.

Hope this helps some how.
Neil

Neil (goofandfroggie) said : #20

Hi
Back again just install again and tried the experimental driver for nvidia.
Well it ran ok,m had Unity running....but my fan on the graphic card was running at full speed so no good for me,
install the first driver (175) still got this message

You need to install this driver if you wish to use the Unity desktop, enable desktop effects, or run software that requires 3D acceleration, such as some games.

install the latest driver. still same message.
But Unity is running not sure what the problem is.
will ask question about driver hope to get help.

But what ever the problem is don't set the desktop cube.
Neil