Screen position skewed

Asked by dave on 2011-01-20

When I open any application, they open in the upper left corner, but it seems as if they open beyond the desktop; i.e., the menu bar of the application is hidden because it is too far up. I am unable to get to my minimize/maximize/close buttons because of this. I have looked through the settings that I could think of. This computer is a laptop connected to an external monitor. The problem happens on either screen, laptop or external. I am running Xfce Desktop environment 4.6.1. I have looked through the tech help section, but to no avail. Any advice would be greatly appreciated, as this issue is getting annoying.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu metacity Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2011-01-20
Last query:
2011-01-20
Last reply:
2011-01-20
Best Sam_ (and-sam) said : #1

Open a terminal and try:
metacity --replace

(This will last only for current session.) If it helps then window manager didn't start correctly.
To exclude user misconfiguration create a test-user and see if the issue remains there.
When test-user doesn't have the issue, revert changes you've made on first user regarding configuration.

CyrusCT (cyrusct) said : #2

I encountered a similar problem with an external monitor on a desktop recently. The screen was also a little fuzzy and auto-adjust didn't fix it. It turned out that the video card was transmitting at 59 Hz and changing it to 60 Hz resolved the problem.

You may want to go to System --> Preferences --> Monitors and verify that your settings are compatible with the monitor, or even try a lower but highly compatible resolution (such as 1024x768) to see if the problem is dependent on the screen resolution which you are using.
____________________
Currently running: Dell Inspiron 1420n w/ Ubuntu 10.10, Franken-HP media center w/ Ubuntu 10.04, Samsung Q1 UMPC waiting for me to troubleshoot a WUBI installation failure.
http://cyrusct.tk/

dave (dave-aka-erebus) said : #3

metacity --replace did nothing, so I went ahead and created a test user. I found out that it is a misconfiguration on my part, although I cannot think of anything I did that would have caused the issue. I will have to look more thoroughly into my profile to see what I may have mistakenly changed. Thank you for your response and your advice.

dave (dave-aka-erebus) said : #4

Thanks Samantha (aka Sam), that solved my question.

Sam_ (and-sam) said : #5

> look more thoroughly into my profile

Hints and workarounds incl. in bug report.