Window controls missing

Asked by Bob Pearson on 2010-07-21

Since upgrading from Ubuntu 9.10 to Ubuntu 10.04 (64-bit) yesterday, the bar for dragging a window round the screen and also normally containing the maximize, minimize and close buttons is no longer there. The controls for resizing the Window are also missing. The problem is particularly severe when using Firefox as it opens at the top of the screen covering the top panel which means I can't run any other applications at the same time. The problem is compounded by the workspace switcher applet only allowing me one workspace, but I will post that as a separate problem.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu metacity Edit question
Assignee:
No assignee Edit question
Solved by:
Bob Pearson
Solved:
2010-07-21
Last query:
2010-07-21
Last reply:
2010-07-21

on a desktop work area without any opened app type ALT-F2 Run Command window:

metacity --replace

Also you can try to disabel desktop effects if they are active from menu System→Preferences→Appearances [visual effects] set to none

Hth

Thanks Marco, that has solved both this question and also my question 118440

Stuart Gillies (gillies) said : #3

I lost the same controls after experimenting with a Knoppix live disk and also a Linux Mint 12 live disk. One of them seems to have messed up the 11.04 settings, despite not being supposed to alter the hard disk settings. This fix restored things as they should be. Appreciated!