KDE unable to start

Asked by Maito on 2009-09-11

Hello, please somebody help me.

I am using Kubuntu 9.04, the system upgraded some programs and asked me to restart the computer, i did it and as always i typed the username ad password, the system started but suddenly stops, a widow appears after a while:

"The following installation problem was detected while trying to start KDE.
No write access to '/home/hercules/.ICE Authority.
KDE unable to start"

The only option was to click in the OK button so i made it, then another window appears telling me the following:

"Could not start KSM server. check your installation"

Does somebody know what to do??? of course i am newbie so please be very detailed.

Thank you very much.

Best regards.

Ivan Pinto
Southeastern Louisiana University
Computer Lab 99

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu meta-kde Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2009-09-14
Last query:
2009-09-14
Last reply:
2009-09-12

Can you please boot to recovery root console (ESC when grub load, select recovery mode, then choose root)

you can now run:

ls -al /home/hercules/.ICE Authority > /home/hercules/output.txt; chown hercules:hercules /home/hercules/output.txt; shutdown -r now

Once rebooted you can open the file in your home directory and paste the output here as an update

Thanks

Maito (ivan-pinto) said : #2

I loaded the console login, as a root (sudo -s) i typed.

ls -al /home/hercules/.ICE Authority > /home/hercules/output.txt; chown hercules:hercules /home/hercules/output.txt; shutdown -r now

The system did something very quicly and reboot but nothing happened, the problem stills there.

Thats fine. Can you now open output.txt in your home directory and provide its contents

Thanks

Maito (ivan-pinto) said : #4

Sorry, how can i do that??

I am in the console and i can see the file but i do not know the command to do it.

Thank you

cat /home/hercules/output.txt

write down what it says and type it here

Maito (ivan-pinto) said : #6

Let me type all what i did:
hercules login: hercules
Password:
hercules@hercules:~$ sudo -su
root@hercules:~# ls -al /home/hercules/.ICE Authority > /home/hercules/output.txt; chown hercules:hercules /home/hercules/output.txt; shutdown -r now

In this moment the system restart itself, i tried to log in but again the windows says that KDE do not start, i start the system as a console one more time:

hercules login: hercules
Password:
hercules@hercules:~$ cat /home/hercules/output.txt
hercules@hercules:~$

And that's all, nothing happen

ok try:

ls -al /home/hercules/.ICE Authority

Thanks

Tom (tom6) said : #8

Hi :)

Do you have an Ubuntu or Kubuntu Cd? Any old one should do. Hopefully you could use that as a LiveCd in your Kubuntu machine
https://help.ubuntu.com/community/LiveCD

That will give a fairly familiar desktop to work with which might help access the file you are looking at. Firefox on the top taskbar should work too.

Good luck and regards from
Tom :)

Maito (ivan-pinto) said : #9

Ok this is what i obtain

hercules@hercules:~$ ls -al /home/hercules/output.txt
-rw-r--r-- 1 hercules hercules 0 2009-09-11 14:16 /home/hercules/output.txt
hercules@hercules:~$

When i use the other command:

hercules@hercules:~$ ls -al /home/hercules/.ICE Authority
not such a file or directory
hercules@hercules:~$

Is that OK?? what i need to do now

Thank you

Tom (tom6) said : #10

Hi :)

I think that was the Home on the LiveCd rather than the one on the hard-drive. To get to the one on the hard-drive go up to the "Places" menu and find the Hard-drive in there

While using the LiveCd please could you open a command-line
https://help.ubuntu.com/community/UsingTheTerminal#Starting%20a%20Terminal
and type in

cd /media
dir

and paste the output of that into here. This should show us how many partitions we can easily look at. Kubuntu on your hard-drive is likely to be /media/disk-1 so try also

cd /media/disk-1
dir

but we don't need the output of that one, just tell us if that looks like linux folders or WIndows ones.

Good luck with this!
Regards from
Tom :)

Vihar (vmankov) said : #11

Your output:
hercules@hercules:~$ sudo -su
root@hercules:~# ls -al /home/hercules/.ICE Authority > /home/hercules/output.txt; chown hercules:hercules /home/hercules/output.txt; shutdown -r now

The last string "shutdown -r now" definitely says (on sudo) the system to reboot immediately.
Why is that?
Does this happen because of the "Authority" that actionparsnip's command line proposed?
Or there's some other problem that causes your system to reboot?

Rethink all the issue please.

Vihar (vmankov) said : #12

Oh, I'm stupid...

I think you'd have to run only once the string of actionparsnip that involves the "shutdown -r now".
After rebooting run it again WITHOUT "shutdown -r now" to see that *.txt file.

Am I right, actionparsnip?

sure that'll fly. I thought you could boot into a different DE and read the file.

If you just run:

ls -al /home/hercules/.ICEauthority

and write down the output. Then report it here

Thanks

Tom (tom6) said : #14

Ahhh, booting into a DE that isn't KDE would get around the problem of not being able to boot into KDE and also avoids needing a LiveCd at all.

Sorry AP
Regards from
Tom :)

I'm betting the user has been running GUI apps with sudo and screwed his/her file ownerships

Maito (ivan-pinto) said : #16

Thanks actionparsnip, that solved my question.

Vihar (vmankov) said : #17

Aplauds, actionparsnip!

*bows low*

Tom (tom6) said : #19

Nicely done :))
Congrats :)

Tom (tom6) said : #20

Err, Maito do you still have the problem or have you totally sorted it now that AP has found the probable cause?