Apostrophe and double quote give wrong characters

Asked by Erik Bakker on 2010-02-14

I am using Kubuntu Karmic, with KDE SC 4.4.0 from the Kubuntu backports PPA.

I think I am using the us_intl keyboard layout, and that is also what I want. The problem is that since the upgrade to KDE SC 4.4.0 I can not write an apostrophe and a double quote anymore. When I hit the apostrophe (') on my keyboard, I get a backtick (`)and when I hit the double quote ("), I get this character: (¨)

This only happens in KDE apps. In Firefox or Eclipse, the keyboard (with deadkeys) works fine.

When I run "setxkbmap us" in a terminal, I get the regular us keyboard layout, which works fine in KDE apps, but then I don't have deadkeys.

In the Keyboard Layout KDE Control Module I have "Disable keyboard layouts" checked, but when I enable it and fiddle around with the various layouts it also doesn't work.

I'd appreciate any help, especially since I can't find anybody else with the same problem.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu meta-kde Edit question
Assignee:
No assignee Edit question
Solved by:
Erik Bakker
Solved:
2010-02-15
Last query:
2010-02-15
Last reply:
Erik Bakker (eamelink) said : #1

This is happening on a Dell XPS M1330 notebook.

Erik Bakker (eamelink) said : #2

This has been solved by running:

$ sudo im-switch -s default-xim

and rebooting, thanks to this thread: http://ubuntuforums.org/showthread.php?t=1404209