FW: Not able to set Wallpaper/Background in Ubuntu Intrepid

Asked by kozlovda on 2009-02-22

Re-posting question, since it was expired:

>> This question was originally filed as bug #317597.
>>
>>Binary package hint: gnome
>>
>>When ubuntu opens and accepts my logon credetials I see the background I have selected for a very brief period then the desktop reverts back to a solid color or gradient.. Depending on how the colors were set up for a specific background. Really strange it is. I can bring up the change background dialog and select different backgrounds. The only thing that changes is the background color and a picture is never displayed.
My resolution is 1680x1050.
>>
>>I've checked the gconf-editor already and the option /desktop/gnome/background/draw_background is "checked".
I've also checked my gconf.xml file and found this part: <entry name="draw_background" mtime="1230064565" type="bool" value="false">
So I've changed the option value to "true" and I rebooted, but nothing changed.
>>
>>I'm hopefull to get a solution here.
>>Regards
>>WebBuddha

Guys, I'll be a bit aggressive, so excuse me in advance :-[ .

THE REPEATABLE APPLICATION MISBEHAVIOR IS INDEED a BUG TOO (any QA or app. developer will tell you the same ;-) ). Not only the crush reason is a bug as it's implicitly assumed in https://help.ubuntu.com/community/ReportingBugs.

There is NO WORKING SOLUTION offered yet to resolve this issue.

As for now after Pedro redirected the bug to support center NO ONE SUGGESTED ANY SOLUTION yet. Furthermore the question https://answers.launchpad.net/ubuntu/+source/meta-gnome2/+question/57594 is already expired (more than 15 days passed). This naturally makes concerned people like me and bug-reporter really unhappy with support :-(

PLEASE PAY at least a little ALIVE HUMAN ATTENTION to such bug-reports. I believe that Pedro's comment is automatically generated upon some condition check (e.g. no dump-file attached).
>> Examining the information you have given us, this does not appear to be a bug report
If you try google search on the comment text, you can find it to be a common bug cancellation text.

My 50 cents to help find out the bug source:
I have Ubuntu 8.10 Intrepid (386).

1. I've updated kernel to 2.6.27.12-generic
2. I used VNC to access ubuntu desktop (some settings could affect accessed desktop background).
3. I used RDP from ubuntu to access Windows desktop (I doubt whether this could relate to the issue)
4. Desktop could accidentally be rebooted due to power supply interruption.

P.S.: sorry for being aggressive :) just wanted to attract an attention to the issue.

Thank you.

Kindly regards,
Dmitry Kozlov.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu meta-gnome2 Edit question
Assignee:
No assignee Edit question
Solved by:
Andy Ferguson
Solved:
2009-02-24
Last query:
2009-02-24
Last reply:
2009-02-22
Best Andy Ferguson (teknostatik) said : #1

Dmitry,

I'll try and deal with your points one by one:

Try not to be aggressive. Most people here don't get paid for working on Ubuntu, and aggression does little to encourage people to contribute. It might be worth looking at http://www.ubuntu.com/community/conduct/ if you're unsure as to what standards of behaviour are acceptable.

From your description it sounds like the issues you are encountering are a result of a change in configuration leading to a result you were not expecting, rather than a bug in the source code of the application. Either way it would be useful to have a backtrace, and also instructions on how we could recreate the symptoms you are encountering.

Bug reports and questions are handled by humans, the majority of whom are volunteers. We do use standard responses to more commonly encountered issues because it gives good continuity of service and ensures that the same problem will be answered in the same way no matter who looks at it.

From your last paragraph you mention that you're using VNC and RDP to access Ubuntu. Do these symptoms still occur when you are accessing the machine directly (sitting in front of it with peripherals plugged in)?

Regards,

Andy

kozlovda (kozlovda-register) said : #2

Hi Andy,

Thank you for your answer. I really appreciate your assistance and time you spent to do this.

Yes, background was absent during the direct desktop session (the same symptoms WebBuddah described). Thanks to your advise I rechecked gnome configuration via gconf-editor an found the key '/desktop/gnome/background/draw_background' not to be checked. I didn't modify configuration manually since the last installation, and didn't find anything similar to that option in system's look'n'feel dialog, so I think the setting was changed programmatically.
I've checked the box and background magically appeared on the desktop :-) Thank you.

As we know the background images are often hidden during the remote session for traffic decrease sake (though I never observed earlier such behavior when accessed my ubuntu desktop - i.e. background was still drawn during remote access). Therefore I was easy when found the background being absent during the last remote session. But upon home return I found that background is still not drawn. I couldn't manage to restore the background myself (I wish to say that I tried to use gconf-editor...), so I searched through i-net and found bug #317597 and expired question #57594 without answer. That's why I recreated the question.

So, checking the key '/desktop/gnome/background/draw_background' solved my problem. Thank you.

Unfortunately, WebBuddah said that his configurations were just fine in terms of background, so my solution doesn't seem to help him. I think in his case the options could be overridden somewhere (more user-specific config file or something like that), or gconf.xml file might be edited in non-sudo mode. I wish him to manage with that problem. :-)

Thank you.

Kindly regards,
Dmitry Kozlov.

kozlovda (kozlovda-register) said : #3

Thanks Andy Ferguson, that solved my question.