No sound when launching some apps from applications menu on fresh 8.04 install

Asked by AFarris01 on 2008-04-29

Im having a strange problem with some of my apps on my new 8.04 install. when i try to launch any of my games from the Applications>Games menu, i have no sound in some of them, and one wont launch from there at all. however, if i launch from terminal directly, all of the games work perfectly, sound included.

i have no problems with sound in gnome, other than that i cant get it pull through all of my speakers, but that doesn't really bother me that much.

One of the games i have, Nexuiz, is helpful enough to have a console, which i checked when i opened the program/launched a new game from within and it said that it couldnt find any of the sound effects, despite the fact that it works perfectly when i use the terminal. this has lead me to believe that there may be some broken links somewhere that are causing the problem, but i have no idea how to go about fixing them, or even why they would have broken.

if anybody knows how i might be able to go about fixing this, i would greatly appreciate the assistance

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu meta-gnome2 Edit question
Assignee:
No assignee Edit question
Solved by:
AFarris01
Solved:
2008-06-07
Last query:
2008-06-07
Last reply:
2008-05-26
AFarris01 (afarris01) said : #1

update:
 ive been looking at it when i can during my free time, and i have more information to add:

only games that i have installed from the online repositories are affected by this issue. all the default games in the gnome-games package have sound and work like they are supposed to from the shortcuts.

all of my games will still launch from the console with properly functioning sound/music and no problems

making a shortcut link on my shortcut bar to any of the games does not enable sound for those with broken sound, and does not disable it for those that work (ive tested this out using nibbles, gnometris, kasteroids, nexuiz, and Angry drunken dwarves) this goes for creating a 'custom launcher' and creating a 'launcher from menu item'

finally, ive noticed something odd that was happening when i was listening to music and playing nibbles. whenever i start playing the music and switch back to nibbles, nibbles has no sound. but after a while, if i close the music player, or go to the 'preferences' in nibbles, all the sounds that should have been playing all along go off in rapid succession. im not sure whats going on, and dont know if its related to this or not, but i thought id throw it in there anyway

i appreciate all ideas as to what to do about this, because at this point im clueless...

AFarris01 (afarris01) said : #2

further update:
After doing some research online i discovered something that shows some different behavior with the shortcuts.

i tried this with the game nexuiz first, because i play it most often. previously if i made a shortcut in the shortcut bar, the sound still would not work. those shortcuts were made with the following commands:
"nexuiz" (direct) & "/usr/games/nexuiz --quiet" (set up by the game on install)

however if i make a shortcut using the following command:
"gnome-terminal -e "/usr/games/nexuiz --quiet"

it works from my shortcut bar. however, a shortcut in the applications>games menu with the exact same command does not yield sound and actually froze the desktop the second time i tried it. does anybody know what might be causing this?

AFarris01 (afarris01) said : #3

Ive noticed just recently that on some of the games that have sound/music menus display the 'enable sound/music' options greyed out and unselectable.

also, i switched from using a 5.1 speaker setup to a single set to do a test and now whenever i run a program from a terminal, whereas before the sound worked now i get an error message:

ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave

but my system sounds are still working. what is going on?

Launchpad Janitor (janitor) said : #4

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

AFarris01 (afarris01) said : #5

Im still having a problem with this. the sound still does not work on certian apps i launch through the gnome menu. the apps that are affected by this:

all games not part of the default gnome game pack
rhythmbox
occasionally wine

apps not affected by this:
system sounds
amorak
apps launched from terminal or desktop
most apps launched from menus in the submenus (IE, wine's menu, a custom menu for NES games)

when i launch the apps that dont work, often the sound options are greyed out as though i have no sound card.

does anybody have any idea of what may be causing this?

AFarris01 (afarris01) said : #6

Ok, i finally fixed it, but completely by accident. i was fiddling with settings in /etc/pulse/daemon.conf to try and get better sound quality, and i saw something in a guide i was reading that if the parameter "use-pid-file" was enabled, then only one audio stream at a time would work. the default vaule is 'yes' so i uncommented it and changed it to 'no', rebooted, and now everything works flawlessly! yey!