after upgrade to Ubuntu 10.10 I have no right or left click in gnome

Asked by Maris Radu on 2010-11-12

On my Presario CQ61-320SQ after upgrading to Ubuntu 10.10 from 10.04, I have problems with the left mouse click and somethimes with all mouse clicks with the touchpad or with the usb mouse. The clicks are working in the login screen, but after login to gnome, I can't click on anything (no click events are triggered), if login in safe mode, the right click works but no look with the left one. after a few reboots login to gnome in safe mode the left click worked but just once, after the first reboot didn't worked anymore. Instaled KDE, all clicks are working if login to KDE.

Please tell me where to get more info to post here, what command to run ... or if somebody knews how to fix it :)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu meta-gnome2 Edit question
Assignee:
No assignee Edit question
Solved by:
Maris Radu
Solved:
2010-11-13
Last query:
2010-11-13
Last reply:
2010-11-12

If you boot normally then press ALT+F2 and run:

metacity --replace

are clicks ok?

Maris Radu (miriade-roo) said : #2

I did a couple reboots, so the results are:
in normal mode after a "metacity --replace" the right mouse click starts working every time, the left one doesn't.
in safe mode, no changes, the right mouse click works at boot time, and the metacity --replace doesn't chage anything in the mouse behavior.

Corection to the original question: The left click doesn't work not the right ( I corected the side in my question )

As a side note: In Ubuntu 10.04 at each boot I had to do a "gnome-panel --replace"

Maris Radu (miriade-roo) said : #3

Updateted xorg-server, xserver-xorg-input-evdev from @Chris Halse Rogers package and the problem is solved. PPA and package can be found here: https://edge.launchpad.net/~raof/+archive/aubergine

Great share! Hopefully this will help others.