How can I develop a GTK+ application in Lucid?

Asked by Gergely Máté on 2010-07-19

I would like to develop a GTK+ application in Ubuntu 10.04. When I try to install the libgtk2.0-dev package, Synaptic complains about broken dependencies.
A broken dependency is libgtk2.0, which is described as "too new".
Other missing dependencies are libglib2.0-dev, libpango1.0-dev, libatk1.0-dev and libcairo2-dev. Synaptic states that those packages are required but not set to be installed.

How do I set up an environment with I am able to build a GTK+ application?

Question information

English Edit question
Ubuntu meta-gnome2 Edit question
No assignee Edit question
Solved by:
Gergely Máté
Last query:
Last reply:
Hans Spaans (hspaans) said : #1

Running the following command should install all the required packages:

$ sudo apt-get install gnome-devel

Gergely Máté (sportember) said : #2

This sound good, but again missing dependencies are reported: libgdl-1-dev.
And libgdl-1-dev is again dependent on libgtk2.0-dev.

Hans Spaans (hspaans) said : #3

Can you post the output of the following:

$ sudo apt-get update && sudo apt-get install gnome-devel

Gergely Máté (sportember) said : #4

gerymate@sportember:~$ sudo apt-get update && sudo apt-get install gnome-develHit lucid Release.gpg
Hit lucid-updates Release.gpg
Hit lucid-security Release.gpg
Hit lucid Release
Hit lucid-updates Release
Hit lucid-security Release
Hit lucid/main Packages
Hit lucid/multiverse Packages
Hit lucid/main Sources
Hit lucid/universe Packages
Hit lucid/universe Sources
Hit lucid-updates/main Packages
Hit lucid-updates/multiverse Packages
Hit lucid-updates/main Sources
Hit lucid-updates/universe Packages
Hit lucid-updates/universe Sources
Hit lucid-security/main Packages
Hit lucid-security/multiverse Packages
Hit lucid-security/main Sources
Hit lucid-security/universe Packages
Hit lucid-security/universe Sources
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  gnome-devel: Depends: libgdl-1-dev (>= 2.28) but it is not going to be installed
               Recommends: gnome-core-devel but it is not going to be installed
E: Broken packages

Gergely Máté (sportember) said : #5

I removed all the repositories except for *main* and *universe*, changed the server, and tried again. It worked.
Thank you for all your help, and especially for the hint on the "gnome-devel" package!