[Lucid] Gnome not run executable file

Asked by stefano.fraccaro on 2010-06-18

I have compiled my c# executable (myprogram.exe) on Windows machine and then I have copied the file to my Linux box.
I add the executable flag to the file. I can run the program from the command line by executing:

$ ./myprogram.exe

but I can't execute the file from the user interface. I can only open the file with Archive Manager or select other application to open with...

Gnome 2.30.0 compiled on 31/03/2010
Ubuntu Lucid Lynx kernel 2.6.32-22

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu meta-gnome2 Edit question
Assignee:
No assignee Edit question
Last query:
2010-06-18
Last reply:
2010-06-18

This question was originally filed as bug #595924.

Pedro Villavicencio (pedro) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs#When%20not%20to%20file%20a%20bug.

Locke (locke-db) said : #2

If the program only uses stdout, then it will output to a terminal. GNOME won't open a shell unless you tell it to. Create a Launcher for your program, and tell it to open Application in Terminal. It does this by setting "Terminal=true" in the .desktop file (launcher) created.

stefano.fraccaro (sf-1) said : #3

my program is a simple C# Windows.Form application. I don't use the terminal in any way... if a file has the executable flag, Gnome (or window manager) should add the "execute" option in the context menu (from my point of view)... why complicate the work by create a shortcut every time?

Can you help with this problem?

Provide an answer of your own, or ask stefano.fraccaro for more information if necessary.

To post a message you must log in.