Unmet dependencies and broken packages - mesa

Asked by Mihail

When i try to install libgl1-mesa-dev with apt-get, I get the following error :

:~$ sudo apt-get install libgl1-mesa-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgl1-mesa-dev : Depends: mesa-common-dev (= 7.11.2~oneiric~ppa1.2) but 8.0.1+git20120316+8.0.7b1fbc68-0ubuntu0sarvatt~oneiric is to be installed
E: Unable to correct problems, you have held broken packages.

I tried with apt-get update, apt-get upgrade, clean, autoclean, and it didn't worked. I even generated a new sources.list on http://repogen.simplylinux.ch/, but still nothing changed.

When I try to install with synaptic i get the same error :

  Depends: mesa-common-dev (=7.11.2~oneiric~ppa1.2) but 8.0.1+git20120316+8.0.7b1fbc68-0ubuntu0sarvatt~oneiric is to be installed

I am using Ubuntu 11.10 amd64.

If it's necessary, my CPU is Intel(R) Core(TM) i5-2430M and my GPU is Intel HD 3000.

Thank you in advance.

Question information

English Edit question
Ubuntu mesa Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

You are using a PPA, I suggest you remove it to see if it smooths out and/or contact the PPA maintainer.

Can you help with this problem?

Provide an answer of your own, or ask Mihail for more information if necessary.

To post a message you must log in.