Error on kubernetes Cluster create "The Parameter (fixed_network_name) was not defined in template."

Asked by Sebastian Schmid

Hello,

i have installed OpenStack Ussuri via Kolla ansible in a "all in one" Installation on Ubuntu 18.04 including Magnum.

The core Modules are working, i could also define a Cluster Template, but on Cluster Create I get the following Error:

Status
    CREATE_FAILED
Status Reason
    ERROR: The Parameter (fixed_network_name) was not defined in template.

I can not find a Parameter "fixed_network_name" in the cluster Template or the Magnum Docs.

Anyone familiar with that Problem?

This is the output of "openstack coe cluster show":
+----------------------+------------------------------------------------------------------------------------------------------------------------------------------------------+
| Field | Value |
+----------------------+------------------------------------------------------------------------------------------------------------------------------------------------------+
| status | CREATE_FAILED |
| health_status | None |
| cluster_template_id | 17e0cf90-aa46-4deb-94d0-588f51c4425e |
| node_addresses | [] |
| uuid | 1fd23a29-c3d5-418e-b5de-88748be9aed0 |
| stack_id | None |
| status_reason | ERROR: The Parameter (fixed_network_name) was not defined in template. |
| created_at | 2020-10-27T15:28:03+00:00 |
| updated_at | 2020-10-27T15:28:07+00:00 |
| coe_version | None |
| labels | {'kube_dashboard_enabled': '0', 'kube_tag': '1.16.2', 'availability_zone': 'nova', 'auto_scaling_enabled': 'False', 'auto_healing_enabled': 'False'} |
| labels_overridden | {} |
| labels_skipped | {} |
| labels_added | {'availability_zone': 'nova', 'auto_scaling_enabled': 'False', 'auto_healing_enabled': 'False'} |
| fixed_network | None |
| fixed_subnet | None |
| floating_ip_enabled | True |
| faults | {} |
| keypair | mykey |
| api_address | None |
| master_addresses | [] |
| master_lb_enabled | False |
| create_timeout | 60 |
| node_count | 1 |
| discovery_url | https://discovery.etcd.io/bb6df4122b6fb40ac379069c9e8504cd |
| master_count | 1 |
| container_version | None |
| name | test |
| master_flavor_id | m1.small |
| flavor_id | m1.small |
| health_status_reason | {} |
| project_id | 3d5630059f3c4e678eea1a76a94c6f3c |
+----------------------+------------------------------------------------------------------------------------------------------------------------------------------------------+

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu magnum Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Sebastian Schmid (sebastian-schmid) said :
#1

Looks like that should be fixed by this commit: https://opendev.org/openstack/magnum/commit/756a85b70cc7fa1b539ec14ab7d1f0e4294264f8

But seems that problem still exists in Ussuri.

Revision history for this message
Dan Vatca (danvatca) said :
#2

It looks as the fixed_network_name was removed from the template configuration, and is now read from the fixed_network object.
However only the heat driver got the memo and the updates.
The coreos, fedora_coreos, fedora_atomic and other drivers are still looking for that parameter.

Revision history for this message
Sebastian Schmid (sebastian-schmid) said :
#3

Thank you for your response and details on that issue. I opened a bug for this and linked it to the discussion here.

Can you help with this problem?

Provide an answer of your own, or ask Sebastian Schmid for more information if necessary.

To post a message you must log in.