which ppa is this package in

Asked by Nick on 2015-05-08

I'm trying to install MaaS on 14.04 from this ppa https://launchpad.net/~maas-maintainers/+archive/ubuntu/stable.
The version in this ppa has a bug as described in here https://bugs.launchpad.net/ubuntu/+source/maas/+bug/1446878.
And here is the updated version of this package https://launchpad.net/ubuntu/+source/maas/1.7.3+bzr3363-0ubuntu2/+build/7351839. My question is how can I install this updated version on my 14.04. I cannot figure out in which ppa this updated version is.

Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu maas Edit question
Assignee:
No assignee Edit question
Solved by:
Nick
Solved:
2015-05-08
Last query:
2015-05-08
Last reply:
2015-05-08
Colin Watson (cjwatson) said : #1

That's not in a PPA at all; it's in the primary Ubuntu archive for 15.04. You could make a PPA of your own and use something like backportpackage to attempt to build it for 14.04, or else ask ~maas-maintainers to build a version for you that you can use on 14.04.

The Launchpad team merely maintains the hosting infrastructure; providing specific packages in PPAs is up to the owners of those PPAs.

Nick (nyt1066) said : #2

I see. So I can install it in 15.04 directly without adding any ppa, right? I'm fairly new to apt and ppa, so some of these updating issues confuse me.
Thanks for clarifying it.

If you mix debs from different releases you may create issues with dependencies and you will end up with a Frankenstein OS.

You have reported a bug, so the package will get updated sooner rather than later.