pvcreate doesn't work in 7.04

Asked by Mike Freeman on 2007-06-25

I've been working with LVM2 for some time under FC3, 4, Ubuntu 6.10. I recently installed Ubuntu 7.04 64bit Server on the same machine that I've been previously using LVM with, however other than during install it is not possible to create Physical Volumes for LVM.

Example:
pvcreate /dev/sdc1
Physical volume "/dev/sdc1" successfully created [that's what it says, but...]
pvdisplay
[..and I only see sdb1, which I created at install.]

I even dismantled a previous Volume Group:
lvremove vg0
vgremove vg0
cfdisk /dev/sdc [no changes made, just checking]
...
sdc1 Primary Linux LVM

pvdisplay
[..and I only see sdb1, which I created at install.]

I've run apt-get update
followed by apt-get upgrade

...but there was no LVM update installed.

What's changed?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu lvm2 Edit question
Assignee:
No assignee Edit question
Solved by:
Mike Freeman
Solved:
2007-06-25
Last query:
2007-06-25
Last reply:
Best Mike Freeman (mike-gman) said : #1

It turns out that pvcreate does work. It's pvdisplay that's flaky. I ran vgextend vg0 /dev/sdc1 and then ran vgdisplay and would you believe it there was an extra pv there. I ran pvdisplay and now it shows up. So it doesn't show up when it is created but it does show up when it is added to a volume group.