Errors were encountered while processing: lvm2 E: Sub-process /usr/bin/dpkg returned an error code (1)

Asked by Cliffm on 2019-11-29

Hello
I'm cliff
Ubuntu 18.04 indicated that there were updates available.
Ran sudo apt update && sudo apt upgrade

This is the end result.

Errors were encountered while processing:
 lvm2
E: Sub-process /usr/bin/dpkg returned an error code (1)

What should I do?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu lvm2 Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2019-11-29
Last query:
2019-11-29
Last reply:
2019-11-29
Manfred Hampl (m-hampl) said : #1

For diagnostic purposes please provide the full output that you receive for the commands

uname -a
lsb_release -crid
sudo apt update
sudo upgrade
df -h

Cliffm (c2mcatee) said : #2

uname -a
Linux Eagle 5.0.0-36-generic #39~18.04.1-Ubuntu SMP Tue Nov 12 11:09:50 UTC
2019 x86_64 x86_64 x86_64 GNU/Linux
lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 18.04.3 LTS
Release: 18.04
Codename: bionic

Filesystem Size Used Avail Use% Mounted on
udev 3.8G 0 3.8G 0% /dev
tmpfs 771M 2.3M 769M 1% /run
/dev/sda1 916G 89G 781G 11% /
tmpfs 3.8G 86M 3.7G 3% /dev/shm
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 3.8G 0 3.8G 0% /sys/fs/cgroup
/dev/loop6 4.3M 4.3M 0 100% /snap/gnome-calculator/544
/dev/loop7 15M 15M 0 100% /snap/gnome-characters/359
/dev/loop0 222M 222M 0 100% /snap/freecad/4
/dev/loop1 324M 324M 0 100% /snap/pycharm-community/163
/dev/loop3 43M 43M 0 100% /snap/gtk-common-themes/1313
/dev/loop5 324M 324M 0 100% /snap/pycharm-community/167
/dev/loop2 68M 68M 0 100% /snap/sublime-text/69
/dev/loop8 45M 45M 0 100% /snap/gtk-common-themes/1353
/dev/loop10 32M 32M 0 100% /snap/java-jre-ondra/6
/dev/loop14 409M 409M 0 100% /snap/netbeans/18
/dev/loop15 141M 141M 0 100% /snap/gnome-3-26-1604/98
/dev/loop9 157M 157M 0 100% /snap/gnome-3-28-1804/110
/dev/loop12 55M 55M 0 100% /snap/core18/1265
/dev/loop11 141M 141M 0 100% /snap/gnome-3-26-1604/97
/dev/loop16 2.0M 2.0M 0 100% /snap/fast/4
/dev/loop21 4.3M 4.3M 0 100% /snap/gnome-calculator/536
/dev/loop22 3.8M 3.8M 0 100% /snap/gnome-system-monitor/107
/dev/loop26 1.0M 1.0M 0 100% /snap/gnome-logs/81
/dev/loop25 1.0M 1.0M 0 100% /snap/gnome-logs/73
/dev/loop27 3.8M 3.8M 0 100% /snap/gnome-system-monitor/111
/dev/loop20 55M 55M 0 100% /snap/core18/1223
/dev/loop24 220M 220M 0 100% /snap/gimp/189
/dev/loop29 397M 397M 0 100% /snap/netbeans/10
/dev/loop17 15M 15M 0 100% /snap/gnome-characters/367
/dev/loop30 157M 157M 0 100% /snap/gnome-3-28-1804/91
/dev/loop31 419M 419M 0 100% /snap/libreoffice/157
/dev/loop23 267M 267M 0 100% /snap/freecad/6
/dev/loop34 68M 68M 0 100% /snap/sublime-text/77
/dev/loop38 90M 90M 0 100% /snap/core/7917
/dev/loop36 90M 90M 0 100% /snap/core/8039
/dev/loop39 8.7M 8.7M 0 100% /snap/canonical-livepatch/88
/dev/loop32 139M 139M 0 100% /snap/thunderbird/29
/dev/loop35 256K 256K 0 100% /snap/gtk2-common-themes/5
/dev/loop42 273M 273M 0 100% /snap/freecad/8
/dev/loop40 8.7M 8.7M 0 100% /snap/canonical-livepatch/84
/dev/loop43 768K 768K 0 100% /snap/ufw/296
/dev/loop41 410M 410M 0 100% /snap/gimp/227
tmpfs 771M 16K 771M 1% /run/user/120
tmpfs 771M 140K 771M 1% /run/user/1000
/dev/loop44 154M 154M 0 100% /snap/chromium/949
/dev/loop28 97M 97M 0 100% /snap/geany-gtk/320
/dev/loop37 154M 154M 0 100% /snap/chromium/958
/dev/loop4 97M 97M 0 100% /snap/geany-gtk/322
/dev/loop13 419M 419M 0 100% /snap/libreoffice/158

sudo apt update && sudo apt upgrade
[sudo] password for cliffm:
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 https://brave-browser-apt-release.s3.brave.com bionic InRelease

Hit:3 http://packages.microsoft.com/repos/vscode stable InRelease

Hit:4 http://mirror.umd.edu/ubuntu bionic InRelease

Hit:5 http://mirror.umd.edu/ubuntu bionic-updates InRelease

Hit:6 http://dl.google.com/linux/chrome/deb stable Release

Hit:7 http://archive.canonical.com/ubuntu bionic InRelease

Hit:8 http://ppa.launchpad.net/webupd8team/java/ubuntu bionic InRelease

Hit:9 http://mirror.umd.edu/ubuntu bionic-backports InRelease
Hit:10 http://mirror.umd.edu/ubuntu bionic-security InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up lvm2 (2.02.176-4.1ubuntu3.18.04.1) ...
update-initramfs: deferring update (trigger activated)
Failed to restart lvm2-lvmetad.service: Unit lvm2-lvmetad.socket is masked.
invoke-rc.d: initscript lvm2-lvmetad, action "restart" failed.
● lvm2-lvmetad.service - LVM2 metadata daemon
   Loaded: loaded (/lib/systemd/system/lvm2-lvmetad.service; static; vendor
preset: enabled)
   Active: inactive (dead)
     Docs: man:lvmetad(8)
dpkg: error processing package lvm2 (--configure):
 installed lvm2 package post-installation script subprocess returned error
exit status 1
Processing triggers for initramfs-tools (0.130ubuntu3.9) ...
update-initramfs: Generating /boot/initrd.img-5.0.0-36-generic
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
Errors were encountered while processing:
 lvm2
E: Sub-process /usr/bin/dpkg returned an error code (1)

On Fri, Nov 29, 2019 at 10:52 AM Manfred Hampl <
<email address hidden>> wrote:

> Your question #686383 on libreoffice in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/libreoffice/+question/686383
>
> Status: Open => Needs information
>
> Manfred Hampl requested more information:
> For diagnostic purposes please provide the full output that you receive
> for the commands
>
> uname -a
> lsb_release -crid
> sudo apt update
> sudo upgrade
> df -h
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+source/libreoffice/+question/686383
>
> You received this question notification because you asked the question.
>

Manfred Hampl (m-hampl) said : #3

What is the output of the commands

cat /etc/modprobe.d/qemu-system-x86.conf
apt --simulate purge lvm2

Cliffm (c2mcatee) said : #4

cat /etc/modprobe.d/qemu-system-x86.conf
options kvm_intel nested=1

apt --simulate purge lvm2
NOTE: This is only a simulation!
      apt needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer
required:
  dmeventd libdevmapper-event1.02.1 liblvm2app2.2 liblvm2cmd2.02
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  lvm2*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
Purg lvm2 [2.02.176-4.1ubuntu3.18.04.1]

On Fri, Nov 29, 2019 at 12:53 PM Manfred Hampl <
<email address hidden>> wrote:

> Your question #686383 on lvm2 in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/lvm2/+question/686383
>
> Status: Open => Needs information
>
> Manfred Hampl requested more information:
> What is the output of the commands
>
> cat /etc/modprobe.d/qemu-system-x86.conf
> apt --simulate purge lvm2
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+source/lvm2/+question/686383
>
> You received this question notification because you asked the question.
>

Manfred Hampl (m-hampl) said : #5

Try the commands

sudo apt purge lvm2
sudo apt install lvm2

and report the results.

Cliffm (c2mcatee) said : #6

sudo apt purge lvm2
[sudo] password for cliffm:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer
required:
  dmeventd libdevmapper-event1.02.1 liblvm2app2.2 liblvm2cmd2.02
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  lvm2*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 3,391 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 302581 files and directories currently installed.)
Removing lvm2 (2.02.176-4.1ubuntu3.18.04.1) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
(Reading database ... 302442 files and directories currently installed.)
Purging configuration files for lvm2 (2.02.176-4.1ubuntu3.18.04.1) ...
Processing triggers for systemd (237-3ubuntu10.33) ...
Processing triggers for ureadahead (0.100.0-21) ...
cliffm@Eagle:~$ sudo apt install lvm2
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  thin-provisioning-tools
The following NEW packages will be installed:
  lvm2
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 928 kB of archives.
After this operation, 3,391 kB of additional disk space will be used.
Get:1 http://mirror.umd.edu/ubuntu bionic-updates/main amd64 lvm2 amd64
2.02.176-4.1ubuntu3.18.04.1 [928 kB]
Fetched 928 kB in 2s (542 kB/s)
Selecting previously unselected package lvm2.
(Reading database ... 302429 files and directories currently installed.)
Preparing to unpack .../lvm2_2.02.176-4.1ubuntu3.18.04.1_amd64.deb ...
Unpacking lvm2 (2.02.176-4.1ubuntu3.18.04.1) ...
Setting up lvm2 (2.02.176-4.1ubuntu3.18.04.1) ...
update-initramfs: deferring update (trigger activated)
Created symlink
/etc/systemd/system/sysinit.target.wants/blk-availability.service →
/lib/systemd/system/blk-availability.service.
Created symlink
/etc/systemd/system/sysinit.target.wants/lvm2-monitor.service →
/lib/systemd/system/lvm2-monitor.service.
Created symlink
/etc/systemd/system/sysinit.target.wants/lvm2-lvmetad.socket →
/lib/systemd/system/lvm2-lvmetad.socket.
Created symlink
/etc/systemd/system/sysinit.target.wants/lvm2-lvmpolld.socket →
/lib/systemd/system/lvm2-lvmpolld.socket.
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Processing triggers for ureadahead (0.100.0-21) ...
Processing triggers for systemd (237-3ubuntu10.33) ...
Processing triggers for initramfs-tools (0.130ubuntu3.9) ...
update-initramfs: Generating /boot/initrd.img-5.0.0-36-generic
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
/etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
with 'group+kvm'
cliffm@Eagle:~$

On Fri, Nov 29, 2019 at 1:43 PM Manfred Hampl <
<email address hidden>> wrote:

> Your question #686383 on lvm2 in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/lvm2/+question/686383
>
> Status: Open => Answered
>
> Manfred Hampl proposed the following answer:
> Try the commands
>
> sudo apt purge lvm2
> sudo apt install lvm2
>
> and report the results.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/ubuntu/+source/lvm2/+question/686383/+confirm?answer_id=4
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/lvm2/+question/686383
>
> You received this question notification because you asked the question.
>

Manfred Hampl (m-hampl) said : #7

Ok, the bigger problem with lvm2 that blocked the package management system seems to be resolved.
Now there is still the problem
"libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
 /etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
 with 'group+kvm'"
open.

The error messages indicates that there is a line with a syntax error in the file /etc/modprobe.d/qemu-system-x86.conf

Please provide the full output of

cat /etc/modprobe.d/qemu-system-x86.conf

including the command prompts shown before and after the command

Cliffm (c2mcatee) said : #8

cat /etc/modprobe.d/qemu-system-x86.conf
options kvm_intel nested=1
group+kvm

On Fri, Nov 29, 2019 at 2:22 PM Manfred Hampl <
<email address hidden>> wrote:

> Your question #686383 on lvm2 in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/lvm2/+question/686383
>
> Status: Open => Needs information
>
> Manfred Hampl requested more information:
> Ok, the bigger problem with lvm2 that blocked the package management
> system seems to be resolved.
> Now there is still the problem
> "libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse:
> /etc/modprobe.d/qemu-system-x86.conf line 2: ignoring bad line starting
> with 'group+kvm'"
> open.
>
> The error messages indicates that there is a line with a syntax error in
> the file /etc/modprobe.d/qemu-system-x86.conf
>
> Please provide the full output of
>
> cat /etc/modprobe.d/qemu-system-x86.conf
>
> including the command prompts shown before and after the command
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+source/lvm2/+question/686383
>
> You received this question notification because you asked the question.
>

Best Manfred Hampl (m-hampl) said : #9

The error message tells that the second line with "group+kvm" is invalid.

I assume that there was an error when changing that config file, and it should be

options kvm_intel nested=1 group=kvm

Cliffm (c2mcatee) said : #10

options kvm_intel nested=1 group=kvm
The group=kvm was group+kvm
ran sudo apt update
Fetched 5,395 kB in 3s (2,073 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done

All packages are up to date.

Thanks Manfred Hampl

On Fri, Nov 29, 2019 at 2:47 PM Manfred Hampl <
<email address hidden>> wrote:

> Your question #686383 on lvm2 in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/lvm2/+question/686383
>
> Status: Open => Answered
>
> Manfred Hampl proposed the following answer:
> The error message tells that the second line with "group+kvm" is
> invalid.
>
> I assume that there was an error when changing that config file, and it
> should be
>
> options kvm_intel nested=1 group=kvm
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/ubuntu/+source/lvm2/+question/686383/+confirm?answer_id=8
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/lvm2/+question/686383
>
> You received this question notification because you asked the question.
>

Manfred Hampl (m-hampl) said : #11

Remark: I am not sure whether "group=kvm" should be at the end of the first line, or standalone in the second.

Cliffm (c2mcatee) said : #12

Thanks Manfred Hampl, that solved my question.