UEFI Boot Entry Not Installed on Xubuntu and Lubuntu 13.04

Asked by Espionage724

I've tried Ubuntu, Kubuntu (a while back), Xubuntu, and Lubuntu 13.04 installers on my two UEFI-compatible computers (one has an ASRock 970 Extreme3 motherboard, the other is an Acer Aspire V3-551G-X419).

If my memory serves me right, Ubuntu and Kubuntu manage to install and leave a bootable entry in my UEFI boot list on both computers, no problem.

Xubuntu and Lubuntu (13.04) however do not leave a boot entry. The installers on both complete without error. Xubuntu 12.04.2 and daily Saucy images leave a boot entry, so this only seems to be related to 13.04. Both computers have Secure Boot disabled also.

A solution I found was to just run boot-repair before leaving the LiveCD after install completes (or boot back into LiveCD), and just reinstall GRUB with the Secure Boot option. The strange part is, I "have" to have Secure Boot checked (even though it's disabled on both computers), or else boot-repair doesn't create the UEFI boot entry at all.

If I understand right, Ubuntu uses a shim thing to do UEFI boots, and this works regardless if Secure Boot is enabled or not. If Secure Boot is disabled, you may see a quick glance of a message stating so before it goes to GRUB. I can confirm that I do see this message when starting up the installer discs for both Lubuntu and Xubuntu 13.04 on both computers.

My guess is is that the UEFI installer can do one of two things. If a non-Secure Boot boot was used, then it would simply place the UEFI files needed to boot in the right locations, and not add a boot entry. This works fine for computers that can look for EFI files (my laptop can do this; desktop can't). If a Secure Boot boot was used, then it would add the files for UEFI with the Shim, and add the EFI boot entry.

So in-short, Lubuntu and Xubuntu 13.04's UEFI installers do not create an EFI boot entry, leading to an unbootable install, at least in my case. Maybe others can leave some feedback?

Question information

English Edit question
Ubuntu lubuntu-meta Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Espionage724 (espionage724) said :

Just did another Lubuntu 13.04 install not too long ago:

On the laptop, no EFI boot entry was created, but my laptop booted it fine (can auto-boot BOOTX64.EFI files I guess). Ran boot-repair, did recommended, it added a "Windows Boot Manager" entry to my EFI boot list, and that works fine. Not sure if it's shim or not.

On the desktop, no EFI boot entry either. Desktop can't boot anything EFI without an entry. Ran boot-repair, and it did not create the "Windows Boot Manager" entry; didn't create anything actually. http://paste.ubuntu.com/5957655/

Did boot-repair again with Purge and Secure Boot enabled: http://paste.ubuntu.com/5957673/

Tried running efibootmgr -c to no avail. efibootmgr only detects my UEFI Lubuntu disc and EFI Shell entries.

Revision history for this message
actionparsnip (andrew-woodhead666) said :

I suggest you report a bug. If you need your system as a functioning workhorse then I recommen 12.04 anyway as it is LTS and supported til April 2017 which is long after even Saucy is EOL. Raring is only supported til January 2014.

Do you have a particular requirement for Raring or are you just highlighting and issue etc?


Revision history for this message
Espionage724 (espionage724) said :

I have no real reason to use Raring, I mainly just chose it since it's the latest. I'm used to OS reinstalls and stuff so support length doesn't really bother me.

After running boot-repair again, a UEFI entry appeared, but it was my EFI seeing the BOOTX64.EFI file (I don't believe this has happened before). It boots fine.

It would seem boot-repair does different things, even if both computers were setup essentially the same exact way (started with a wiped single HDD in MBR, booted up a LiveCD in UEFI, installed, ran boot-repair, rebooted) and have the same problem (no boot entry).

I'll report this as a bug though.

Revision history for this message
ԜаӀtеr Ⅼарсһуnѕkі (wxl) said :

Seems that the bug has expired and I've seen no further complaints, so this should be considered resolved.

Can you help with this problem?

Provide an answer of your own, or ask Espionage724 for more information if necessary.

To post a message you must log in.