G5 MAC ppc Lubuntu 12.10 takeing forever at "returning from Prom_init" Is it frozen or what?

Asked by Logan on 2013-01-08

So I am trying to install a G5 Power Pc with lubuntu-12.10-desktop-powerpc. It stops on "Returning from prom_init". I'd love to know what's happening, If this is just normal, and lack of graphical support for the power pc results in it seeming frozen while stuff is actually happening. Or is it freezing, which by the way is a little scary as the fans ten to speed up and the g5 is a monster. Mine has 2 dual core 3ghz cpu's. I'd love to get this monster runing linux, I don't have the original mac cd's. I also already know it's supposed to be imposible to install the newest mac os on it, which I would have liked to do so I can work on programming Iphone apps. Anyways any help or suggestions is appreciated. Last time I tried booting it I pressed tab and selected live 64 boot option.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu lubuntu-meta Edit question
Assignee:
No assignee Edit question
Last query:
2013-01-09
Last reply:
2020-02-22

It seems your PC is experiencing the following bug, for which there is no solution yet:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/912071

  Try the following boot option to change the video driver used during boot.

  boot: linux video=ofonly

Source: http://lists.fedoraproject.org/pipermail/ppc/2012-March/001497.html

My suggestion may not help. This is NOT looking good:

http://tech.danbarrese.com/2011/06/27/power-mac-g5-fails-to-boot/

The system uses an Nvidia GPU, this has zero bearing on the fact you are using a PPC CPU.

Did you try the boot option:

nouveau.blacklist=1

Logan (cormier66) said : #6

So, I tried boot option :linux video=ofonly before same thing. nouveau.blacklist=1 I'm not sure how to implement this I tried it in the boot menu and It told me something was missing, pressing tab for boot options doesn't come up with anything similar either.

Logan (cormier66) said : #7

I would also like to ask if it's the video card, can I replace a video card in a g5 with something else, I mean I thought of just removing it but I don't see any connection for video on the motherboard.

Logan (cormier66) said : #8

Also according to what I read from your reply's this problem may not of existed with kernel 2.6.9 so which ubuntu had that kernel? How can I check?

Adam Cajander (cajander1111) said : #9

Try installing 12.04. The bug seems to exist on that release as well but its worth a shot. If not, try 11.10, then 11.04. I doubt you'll have to go that far back though. Also out of curiosity, why such a light desktop such as Lubuntu, when you have 4, 3ghz processors?

Adam Cajander (cajander1111) said : #10

I mean 2 dualies***

Logan (cormier66) said : #11

:P To answer your question about the light desktop, It's because It was the first link I got off of Ubuntu's power PC site, I'm really more interested in just getting anything running on it. Besides my plans for this computer really have to do with my own code, which I plan on optimizing for the four cores. So as long as the desktop runs, It's probably enough to start.

Walter Lapchynski (wxl) said : #12

This should be considered "solved" in two senses:
 1. The bug got fixed.
 2. PPC has been dropped from Ubuntu, so it's kind of irrelevant.

Can you help with this problem?

Provide an answer of your own, or ask Logan for more information if necessary.

To post a message you must log in.