Extremely choppy video playback

Asked by Ben on 2012-04-18

My video playback is very choppy, particularly online videos. Even when I let the video buffer, it still is choppy, or the sound doesn't match the picture. I am running Lubuntu 11.10, and I have tried setting the global storage for flash player all the way down, disabled hardware accelerator, made sure I was not running other programs and anything else I could think of. My internet connection is pretty good, as I play online games on my xbox and also play youtube on my xbox with no problems. This problem did not exist with XP, so I really don't think it's a hardware issue. I just have no idea what to try. The main reason I have this old computer is that I want to watch Netflix and Youtube with it. Also, I am still new to Linux, so any suggestions are good, even if it's something very simple I might be missing. Oh, and I do have the latest version of Flash player. One more edit: Shockwave flash crashes quite frequently.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu lubuntu-meta Edit question
Assignee:
No assignee Edit question
Solved by:
Ben
Solved:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

Flash isn't owned by Shockwave and hasn't been for ages. It is now owned by Adobe and has been since 2005!

Can you give the output of:

sudo lshw -C display; lsb_release -a; uname -a; lsb_release -a

Thanks

Revision history for this message
Ben (granturismoguy) said :
#2

Lol you must be getting sick of all my questions. The only reason I said Shockwave was because that's what it says when it crashes. (shows how much I know) Once again, thank you. Here's the info:

*-display
       description: VGA compatible controller
       product: NV43 [GeForce 6600 GT]
       vendor: nVidia Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       version: a2
       width: 32 bits
       clock: 66MHz
       capabilities: pm agp agp-3.0 vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=248 maxlatency=1 mingnt=5
       resources: irq:19 memory:e5000000-e5ffffff memory:d0000000-dfffffff memory:e6000000-e6ffffff memory:e7000000-e701ffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
Linux ben-A7N8X-E 3.0.0-17-generic #30-Ubuntu SMP Thu Mar
86 athlon i386 GNU/Linux
No LSB modules are available.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#3

Ok and the output of:

dpkg -l | grep nvidia

Thanks

Revision history for this message
Ben (granturismoguy) said :
#4

ii nvidia-common 1:0.2.35 Find obsolete NVIDIA drivers
ii nvidia-current 280.13-0ubuntu6.1 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-settings 280.13-0ubuntu2 Tool of configuring the NVIDIA graphics driver

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#5

kinda old, ok run:

sudo apt-get --purge remove nvidia-settings nvidia-current

sudo apt-get --purge autoremove

sudo apt-get clean

Then reboot and run:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

sudo apt-get update

sudo apt-get install nvidia-current

Reboot, you now have the 295 driver.

Revision history for this message
Ben (granturismoguy) said :
#6

Well, I tried that, but it didn't seem to do anything. Maybe it is my old hardware. One thing I forgot to mention was that when I play a DVD, even though it's nowhere near as bad as online videos, it is still a little choppy. I don't know whether I should just give up on this dinosaur or maybe upgrade it a bit.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#7

Tried with Unity2D session?

Revision history for this message
Ben (granturismoguy) said :
#8

OK, another softball question :what do I need to do to get Unity 2D? I try to log in to a 2D session and it just doesn't seem to accept my username and password. When I finish tping the password it just brings up a blank username space again.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#9

Log off, click the cog near your username and choose a different session. Do they make a difference?

Revision history for this message
Ben (granturismoguy) said :
#10

I don't know where that cog is. When I log off the only tings on the screen are desktop choice and language choice. There is nothing else to click on. Unity 2D is not even one of those desktop choices, but there is Lubuntu (I think) 2D

Revision history for this message
marcobra (Marco Braida) (marcobra) said :
#11

Please press on little Ubuntu at right of you login name, and select Ubuntu-2d

Revision history for this message
Ben (granturismoguy) said :
#12

Sorry I took so long to reply, my keyboard kicked the bucket and I had to get a new one. Anyway, just for kicks the other day, I decided to install Mint 12 LXDE. I hope that's not hated by Ubuntu users, not sure if it is considered a hated rival or just another flavor. Anyway, after booting from the CD, the video playback seemed much better, so I completely got rid of Ubuntu and kept Mint. Now I have no problem with playback. I'm assuming there must have been something off in Ubuntu, and it may have been something I did, but in either case, it's fixed. Thank you everyone for all the help.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#13

Its not hated, just not supported in the Ubuntu channels :)