After upgrade Lubuntu to 11.10: Lost auto-logon. Getting worse.

Asked by Kenkoy Ayokona on 2012-02-27

Hi! I upgraded my old Athlon's Lubuntu yesterday to 11.10. It lost its auto-logon. I've been thru umpteen web sites showing how to get it back, and each DIFFERENT technique makes things worse. The last I tried left multiple log-on steps with drop-down menus. I'm afraid to try any more.
Using Nano, I can create the uncommented line "autologin=<my user name>", but whether I click Ctrl+X or Ctrl+O, it only saves default.conf as new files called default.conf.save.#, leaving the original still in effect.
A "sudo update-alternatives --config lxdm.conf" technique made things even worse, leading to multiple drop-down menus on bootup.
Yipes! Now the system only boots to a blank black screen.
I'm worried about the Ubuntu I have on my main machine. It's due for upgrade, too, but my work there is FAR too critical to waste time with these ridiculous problems.
Possibly you can advise me, instead, therefore, on a Linux distro more suited to me, which doesn't change its various structures and commands every time it's upgraded. I'm too busy to parse thru the multiple, conflicting, tutorials!
Other than that, Ubuntu/Lubuntu are beautiful, fast OS's, which would conquer the world, if only...
Thanks very much for any guidance you can offer!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu lubuntu-meta Edit question
Assignee:
No assignee Edit question
Solved by:
Kenkoy Ayokona
Solved:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

It's autologin, wait til the work is done and submitted, then mess with your OS.

I suggest that instead of upgrading you should clean install the OS, your old configs will not cause conflicts and so on in the new versions. Makes life a lot easier.

Revision history for this message
Kenkoy Ayokona (watamidoinir) said :
#2

Thanks, actionparsnip! My internet service is extremely slow, so I've tried to avoid those day-long download/installations, for each machine. But I think you're right.

I don't understand what you meant by "It's autologin." That is what I entered in the command line. Not "auto-login" or autologon, etc.

Can anyone explain how to save a file in Nano without it just creating the edit as a new file, as I noted above?

And I can't really "wait til the work is done and submitted" That'll never be finished. If I'm lucky, it'll be ramped up. I just wanted to get out of the Microsoft grip - I can't afford their junk anymore, anyway.

Ok, thanks again. I guess there's no Linux distro that's less constantly "evolving," though, right?

Revision history for this message
BCW142 (bcw142) said :
#3

sudo nano

Edit the file as root and you can save it, same for most anything under /etc
Another tip is to keep another sudoer logon for when yours goes crazy, that just saved me today. I set one up for my sister but had to use it myself to do something about my original logon as it's gone crazy. It just loops, I enter my password and it asks again. If your having major problems, if you hold the shift key down (as the BIOS finishes) it forces you into the Grub menu (even when you can't see it), then wait (holding shift) for about 10 seconds or more, let up and hit enter. That forces you into the normal boot even when things are pretty crazy. The same thing (shift) then a down arrow and enter gets you into 'Recovery Menu' with a number of things you can do (or try).
To add another user:
sudo adduser USERNAME
USERNAME should be the users name (logon), generally in all small letters, After it's made and has a password (it will prompt you) do:
sudo adduser USERNAME sudo
to add them to sudoers so their password can get them root access when needed.

Revision history for this message
Kenkoy Ayokona (watamidoinir) said :
#4

Hi BCW142. I really appreciate your response here after so much time. I no longer have Lubuntu, and in a quick search, can't even find my records describing the problems I was having with it. About a year ago, I replaced it with Linux Mint, which has run beautifully without any problems ever since. It might just be a weird incompatibility with my machine that caused the problems before. I'll hold on to these suggestions, though, for possible use in the future. Thanks again, very much, for offering the help. Cheers!