How do I install Lubuntu desktop using the terminal

Asked by folmez on 2010-11-11

My laptop has ubuntu 8.04 installed, and I would like
to install Lubuntu on it without having to burn a CD or
to use a flash disk? Is it possible?

What is the way to do it in the terminal?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu lubuntu-meta Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Jayson Vaughn (thedonvaughn) said :
#1

I'm at work, so I'm not 100% sure, but you should be able to:
sudo aptitude install lubuntu-desktop

Revision history for this message
folmez (folmez) said :
#2

It doesn't find the lubuntu-desktop package, hence does not install anything.

Revision history for this message
arochester (arochester) said :
#3

Ubuntu-desktop, kubuntu-desktop and xubuntu-desktop are meta-packages i.e. they each install a bunch of stuff. As far as I know there is no lubuntu-desktop.

If you have ubuntu and installed e.g. kubuntu-desktop you would be able to choose either Gnome or KDE but you would end up with a mixture for Gnome apps AND KDE apps together. Psychocats explains this. Look at http://www.psychocats.net/ubuntu/kde ."Warning: having KDE and Gnome together means you'll have cluttered application menus full of KDE applications and Gnome applications."

Lubuntu is based on the LDXE desktop. You can apt-get install LDXE. BUT, similarly, you will end up Gnome apps. Psychocats has s section on "Getting Back to a Pure LXDE on Ubuntu" BUT THAT ONLY REFERS TO UBUNTU 10.10 MEERKAT. That way someone who ran a mixture of Gnome and LDXE courd remove Gnome.

So, my best advice, with 8.10 is to just install LDXE. OK, it's not full blown, official Lubuntu, but it's on the road

Revision history for this message
Jayson Vaughn (thedonvaughn) said :
#4

Oh, maybe it's just not in repos for 8.04?

I definitely have the lubuntu-desktop package in 10.10. It's in the multiverse repository.

jvaughn@mingus:~$ sudo aptitude search lubuntu-desktop
p lubuntu-desktop - Lubuntu Desktop environment
jvaughn@mingus:~$

Revision history for this message
marcobra (Marco Braida) (marcobra) said :
#5

Please first enable the multiverse repository:

Open System → Administration → Software sources → [ Tab Ubuntu software ]
enable "Software restrictecd by copyright or legal issue ( multiverse )"
Close and confirm the repository reload.

Then open a Terminal from the menu Applications → Accessories → Terminal and type:

sudo aptitude update
sudo apt-get dist-upgrade
sudo apt-get clean
udo aptitude update
sudo aptitude install lubuntu-desktop

give your user password when requested, you don't see nothing when you type it, then press enter.

Revision history for this message
marcobra (Marco Braida) (marcobra) said :
#6

The previous command is valid for the Ubuntu 10.10 repository so please try on Ubuntu 8.04 repositories, might be you can't find lubuntu-desktop into Ubuntu 8.04 repository

Can you help with this problem?

Provide an answer of your own, or ask folmez for more information if necessary.

To post a message you must log in.