lubuntu - how to setup a proxy? (not a bug)

Asked by hawran on 2010-08-21

I apologise for any inconvenience, I just couldn't find where to ask for new(?) features.
Is there any possibility for setting up a proxy the same way as in Ubuntu?
I mean, to setup a system-wide proxy settings without restarting a session ...

some info:
Lubuntu 10.04
Linux ... 2.6.32-24-generic #41-Ubuntu SMP Thu Aug 19 01:12:52 UTC 2010 i686 GNU/Linux

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu lubuntu-meta Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:

This question was originally filed as bug #621832.

Revision history for this message
Vallery Lancey (muscovy) said :
#1

I've turned this report into a question to help you get answers, and to help clean up the bug list.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#2

export http_proxy=http://username:<email address hidden>:port/
export ftp_proxy=http://username:<email address hidden>/

replace username,password,proxyserver and netport with your details, if you dont have authentication on the proxy then use the format:

export http_proxy=http://proxyserver.net:port/
export ftp_proxy=http://proxyserver.netport/

Should be ok

Revision history for this message
hawran (hawran.diskuse) said :
#3

I presume this is just a workaround.
The scope of the proxy settings is a shell I export those variables within.

1. What is the best point to place this setting to get the system-wide scope?
2. Would it be possible to change it without a restart?

Revision history for this message
Launchpad Janitor (janitor) said :
#4

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Revision history for this message
hawran (hawran.diskuse) said :
#5

So there are not any (simple) answers to the questions?
:-(

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#6

yes, use the ~/.bashrc file, it will apply system wide. Just add the 2 lines as I showed and it will apply at boot.

Revision history for this message
Victor Engmark (victor-engmark) said :
#7

Same problem here. You can't just set proxy variables in .bashrc and expect Firefox or other non-shell programs to pick up on them.

Can you help with this problem?

Provide an answer of your own, or ask hawran for more information if necessary.

To post a message you must log in.