Cannot turn off fans

Asked by Adriaan on 2009-10-19

Ubuntu by default is handling my fans very bad. The fans blow harder then needed. That's why i created a script which runs fine on earlier ubuntu. Can u tell me how to do this on karmic? What is the official way to tune the fans?

for a in /proc/acpi/fan/*; do
 echo -n 3 > $a/state; #turn off the fan
done

ProblemType: Bug
Architecture: amd64
Date: Mon Oct 19 10:25:37 2009
DistroRelease: Ubuntu 9.10
Package: lm-sensors (not installed)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
ProcVersionSignature: Ubuntu 2.6.31-14.46-generic
SourcePackage: lm-sensors-3
Uname: Linux 2.6.31-14-generic x86_64

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu lm-sensors-3 Edit question
Assignee:
No assignee Edit question
Last query:
2009-10-19
Last reply:
2009-10-23

This question was originally filed as bug #455255.

Adriaan (adriaanvk) said : #1
Chris Coulson (chrisccoulson) said : #2

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs .

Colin Ian King (colin-king) said : #3

Although a little old and possibly out of date, there is a good section on setting fan speeds here:

http://ubuntuguide.org/wiki/Ubuntu_Edgy#How_to_detect_CPU_temperature.2C_fan_speeds_and_voltages_.28lm-sensors.29

Can you help with this problem?

Provide an answer of your own, or ask Adriaan for more information if necessary.

To post a message you must log in.