dbgsym packages missing on http://ddebs.ubuntu.com focal-updates

Asked by Simon Aittamaa on 2021-04-14

The relevant -dbgsym packages are missing on ddebs.ubuntu.com for focal-updates.

This was checked against the Packages file (binary-amd64, and binary-i386) with a timestamp of 2021-04-13 17:22.

Not sure if this is the right forum for this. If not, any pointer as to where I should raise this concern would be greatly appreciated!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu llvm-toolchain-11 Edit question
Assignee:
No assignee Edit question
Last query:
2021-04-21
Last reply:
2021-04-22
Simon Aittamaa (simait) said : #1

The packages that should be in the Packages file are available in the pool, i.e.: http://ddebs.ubuntu.com/pool/universe/l/llvm-toolchain-11/

Perhaps something it's just the generation of the Packages file that is broken?

Manfred Hampl (m-hampl) said : #2

The version number for llvm-toolchain-11 in focal-updates is 1:11.0.0-2~ubuntu20.04.1

The -dbgsym packages are available in http://ddebs.ubuntu.com/ubuntu/pool/main/l/llvm-toolchain-11/ (main, not universe!), however they seem to be missing in the Packages{,gz,xz} files

The publishing history https://launchpad.net/ubuntu/+source/llvm-toolchain-11/+publishinghistory shows that the package started in universe and then was moved to main. Maybe the problem is related to that.

I suggest that you create a question document in "Launchpad itself" or re-assign this question document to that area. Hopefully the Launchpad admins can identify the root cause and find a way to correct this.

Manfred Hampl (m-hampl) said : #3

I am very sure that the dbgsym packages were available in the pool directory, but I cannot find them any more.
Very strange.

Manfred Hampl (m-hampl) said : #4

Remark: You should set the status to "open" again (by putting something into the 'Message:' box pressing the related button).

Simon Aittamaa (simait) said : #5

Ah, thanks!

There are a _lot_ of dbgsym packages in the universe pool at least: http://ddebs.ubuntu.com/pool/universe/l/llvm-toolchain-11 at least? (just not in the Release file).

Manfred Hampl (m-hampl) said : #6

None of these is in the version for focal (1:11.0.0-2~ubuntu20.04.1)
11.0.0-2 is for groovy
11.0.1-2ubuntu1, 11.0.1-2ubuntu2 and 11.0.1-2ubuntu4 are for hirsute (the first two already superseded by the last one!)

I still assume that this was somehow caused by moving the package from universe to main.

Colin Watson (cjwatson) said : #7

We're tracking this as https://bugs.launchpad.net/ddeb-retriever/+bug/1921940, though I haven't had time to do anything about it yet. I'm going to close this question, since it's not a Launchpad problem as such.

Colin Watson (cjwatson) said : #8

(I know that that bug is nominally about a different package, by the way. I expect it to be the same issue.)

Simon Aittamaa (simait) said : #9

Okies, as long as it's not forgotten :)

Manfred Hampl (m-hampl) said : #10

Now that the Launchpad admins have provided their comments, I am moving the question back to the Ubuntu area.

As a workaround you can do the following:

Install the llvm program packages as desired (I expect this to work without problems) and then manually download and install the related dbgsym packages from Launchpad. On https://launchpad.net/ubuntu/+source/llvm-toolchain-11/1:11.0.0-2~ubuntu20.04.1
In the right upper part there is a headline "Builds", open the link for the architecture that you are using (probably amd64) and you get https://launchpad.net/ubuntu/+source/llvm-toolchain-11/1:11.0.0-2~ubuntu20.04.1/+build/20273863 and from there you can manually download the ddeb files (bottom half "Built files").

e.g.
wget https://launchpad.net/ubuntu/+source/llvm-toolchain-11/1:11.0.0-2~ubuntu20.04.1/+build/20273863/+files/llvm-11-dbgsym_11.0.0-2~ubuntu20.04.1_amd64.ddeb
sudo dpkg -i llvm-11-dbgsym_11.0.0-2~ubuntu20.04.1_amd64.ddeb

Can you help with this problem?

Provide an answer of your own, or ask Simon Aittamaa for more information if necessary.

To post a message you must log in.