Selecting Dvorak during install does not apply to whole machine

Asked by Antonios Hadjigeorgalis on 2018-02-04

I recently installed Ubuntu 17.10 via the live-installer on a new ssd drive in a lenovo laptop. When running through the installer I set up my user and keyboard settings to English-dvorak. When I launched the newly installed system, the GDM greeter was not set to dvorak, but standard English qwerty. Also root user was also setup with standard English qwerty. In the current state of the machine, to login or use a sudo command I need to type as if my keyboard is qwerty. When working as my user I can type dvorak and it works. For example, web pages and terminal windows accept my dvorak typing.

Questions:
- How can I apply dvorak keyboard settings to all users of the machine? After an hour of searching for a solution I did not find anything useful. My plan is to reinstall as standard english and then apply dvorak settings after install. I'd rather just reconfigure the existing system if possible.

- How best should I report this as a bug in the installer?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu live-installer Edit question
Assignee:
No assignee Edit question
Last query:
2018-02-04
Last reply:
2018-02-05

Can you help with this problem?

Provide an answer of your own, or ask Antonios Hadjigeorgalis for more information if necessary.

To post a message you must log in.