Bttv Leadtek WinFast 2000XP worked perfectly, then didn't on reboot

Asked by Aaron Whitehouse on 2009-11-16

Binary package hint: lirc

I have filed this as a bug through ubuntu-bug so that all the correct files are attached. Then I'm hoping to convert it to a question, as I realise that is more appropriate. Sorry if things don't go to plan, there doesn't seem to be a way to get apport to attach things to an "Answer". Hopefully it will keep the attachments when I convert it.

I have a bttv Leadtek 2000XP
03:07.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
I: Bus=0001 Vendor=107d Product=6609 Version=0001
N: Name="bttv IR (card=34)"
P: Phys=pci-0000:01:06.0/ir0
H: Handlers=kbd event5
B: EV=100003
B: KEY=8fc736 2350000 0 0 0 10000 10000 190 40004801 1e0001 fff80 0 4002

I set it up by following the steps here:
http://www.linuxtv.org/wiki/index.php/Leadtek_WinFast_2000#Setting_up_the_remote
and here:
http://www.mythtv.org/wiki/Leadtek_WinFast#Remote

I wrote both the guides, so please tell me if I have done something stupid (and don't assume that the guides are 100%).

Essentially, I set up a udev symlink for the remote event device, as it changed each boot. I started lirc with:
sudo /usr/sbin/lircd --device=/dev/input/event5 --driver=dev/input
(I had to sudo mkdir /var/run/lirc first, as I got an error that it couldn't create the lock file. This was before I had created the udev symlink of "bttv_remote")
and everything worked fine. I was using MythTV happily and the remote let me use all of the buttons that I had configured (which was a lot better than what Mythbuntu Control Centre did for my card). Irw worked entirely as expected.

After restarting, LIRC is not working correctly. Irw gives nothing when buttons are pressed. MythTV does not respond to presses at all. However, typing:
$ sudo evtest /dev/input/bttv_remote
[sudo] password for mythbuntu:
Input driver version is 1.0.0
Input device ID: bus 0x1 vendor 0x107d product 0x6606 version 0x1
Input device name: "bttv IR (card=34)"
Supported events:
  Event type 0 (Sync)
  Event type 1 (Key)
    Event code 2 (1)
[snip]
  Event type 20 (Repeat)
Testing ... (interrupt to exit)
Event: time 1258356979.584032, type 1 (Key), code 2 (1), value 1
Event: time 1258356979.584042, -------------- Report Sync ------------
Event: time 1258356979.584046, type 1 (Key), code 2 (1), value 0
Event: time 1258356979.584048, -------------- Report Sync ------------
Event: time 1258356980.309671, type 1 (Key), code 3 (2), value 1
Event: time 1258356980.309680, -------------- Report Sync ------------
Event: time 1258356980.309684, type 1 (Key), code 3 (2), value 0
Event: time 1258356980.309686, -------------- Report Sync ------------
Event: time 1258356981.074843, type 1 (Key), code 78 (KPPlus), value 1
Event: time 1258356981.074853, -------------- Report Sync ------------
Event: time 1258356981.074858, type 1 (Key), code 78 (KPPlus), value 0
Event: time 1258356981.074861, -------------- Report Sync ------------

So it seems to me that the udev symlink and remote driver are working correctly, but somehow my LIRC settings are incorrect.

I will attach my /etc/lirc/hardware.conf, as that seems the most logical place for a mistake that would cause this.

Any help, or further tests, that anyone can give would be greatly appreciated!

ProblemType: Bug
Architecture: amd64
Date: Mon Nov 16 20:13:54 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Mythbuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
Package: lirc 0.8.6-0ubuntu2
ProcEnviron:
 LANG=en_NZ.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: lirc
Uname: Linux 2.6.31-14-generic x86_64
XsessionErrors:
 (polkit-gnome-authentication-agent-1:1993): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (xfce4-terminal:3281): Terminal-WARNING **: Unable to load terminal preferences.
 (xfce4-terminal:3428): Terminal-WARNING **: Unable to load terminal preferences.
 (xfce4-terminal:3544): Terminal-WARNING **: Unable to load terminal preferences.
 (xfce4-terminal:4026): Terminal-WARNING **: Unable to load terminal preferences.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu lirc Edit question
Assignee:
No assignee Edit question
Solved by:
Aaron Whitehouse
Solved:
2009-11-18
Last query:
2009-11-18
Last reply:
2009-11-16

Sorry for the noise, I was hoping for "ubuntu-bug" to pick up all files relevant to lirc.

Interesting -- when you convert a bug to a question, all attachments are replaced with blank comments. Please see the bug for the attachments.

This was solved on this list:
http://old.nabble.com/Bttv-Leadtek-WinFast-2000XP-worked-perfectly,-then-didn%27t-on-reboot-td26369173.html

I was using "dev/input" instead of "devinput" and was pointing to the Leadtek remote configuration (used for accessing the remote directly) instead of the linux-input configuration files.