Trying to recompile the Ubuntu Jaunty 32-bit server kernel: compile runs out of space

Asked by tmerriam on 2009-10-08

I'm trying to recompile the Ubuntu Jaunty 32-bit server kernel, but at the point where it tries to build the .deb files, it gives an error saying I ran out of space. /usr still has 6GB free at this point, and none of the other volumes are filled. Where is it trying to write?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux Edit question
Assignee:
No assignee Edit question
Solved by:
tmerriam
Solved:
2009-10-15
Last query:
2009-10-15
Last reply:
2009-10-15
zvacet (ivicakolic) said : #1

In terminal

df -h

Post output.

tmerriam (tmerriam87) said : #2

Filesystem Size Used Avail Use% Mounted on
/dev/mapper/vg-root 969M 154M 766M 17% /
tmpfs 1.5G 0 1.5G 0% /lib/init/rw
varrun 1.5G 236K 1.5G 1% /var/run
varlock 1.5G 4.0K 1.5G 1% /var/lock
udev 1.5G 208K 1.5G 1% /dev
tmpfs 1.5G 404K 1.5G 1% /dev/shm
lrm 1.5G 2.2M 1.5G 1% /lib/modules/2.6.28-15-generic/volatile
/dev/sda1 107M 20M 82M 19% /boot
/dev/mapper/vg-home 881G 388G 449G 47% /home
/dev/mapper/vg-opt 194M 5.6M 179M 4% /opt
/dev/mapper/vg-tmp 194M 5.6M 179M 4% /tmp
/dev/mapper/vg-usr 15G 4.1G 10G 30% /usr
/dev/mapper/vg-var 1008M 310M 648M 33% /var
/dev/mapper/cryptextra
                      459G 265G 171G 61% /mnt/cryptextra

Colin Ian King (colin-king) said : #3

How are you building this kernel?

What is the exact error message?

Colin Ian King (colin-king) said : #4

You may be running out of free inodes, what do you get with df -i ?

tmerriam (tmerriam87) said : #5

df -i shows that most of the partitions only use 1-3% of the available inodes. /usr and /var use a bit more, 16% and %14, but that should be enough, right? I'm compiling my kernel according to the instructions according to this https://help.ubuntu.com/community/Kernel/Compile

Else where on the web, someone suggested that there isn't enough free space on /tmp and to set TMPDIR. /tmp is only 1GiB on my computer. That doesn't fix it though, either the script doesn't read that variable or that's not the problem.

I tried compiling it on a VirtualBox, and it worked, but the package had other issues, so I've given it up. I'll probably do a clean install of 64bit Karmic when it comes out.