Where to find patch for bug # 268502

Asked by eddin on 2009-08-23

I refer to bug # 268502. The web page for the bug mention that there are three patches for eliminate this bug, but I do not see where to get the patches.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux Edit question
Assignee:
No assignee Edit question
Solved by:
eddin
Solved:
2009-08-28
Last query:
2009-08-28
Last reply:
2009-08-28
Tom (tom6) said : #1

Usually when those bug-reports say "Fix Released" then the patches just appear in normal updates a little while later, usually a day or 2. So hopefully now you have the update already?

Regards from
Tom :)

eddin (eddinw) said : #2

But the bug is apparently still present in my system. I believe my system has the latest updates. I was thinking that if I can find the patch, I can apply the patch to my system directly.

Rolf Leggewie (r0lf) said : #3

Patches usually aren't applied to a system directly. They are applied to the source code which then needs to be recompiled. That requires skill. It's better to just wait for the fixed binary package to arrive.

What release of Ubuntu are you running? If you are running Intrepid or later and are still affected by that bug even after updating all packages (you have intrepid-updates or jaunty-updates repository enabled, don't you?), then you should you reopen the ticket. Click on the appropriate upside-down eject button on the top right to do that. Leave a comment explaining your situation.

HTH. Good luck

Tom (tom6) said : #4

The upside down 'eject' (re-inject?) buttons are in the bug-report
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/268502
but i am quite timid and would start by just adding a new comment to the end there to ask for help. I know that means displaying all 252 messages but i think that would be worth it.

Good luck and regards from
Tom :)

eddin (eddinw) said : #5

Thanks for the answers. But, two out of three bluetooth dongles I have do not work in Jaunty. I believe I have the latest kernel updated in my computer.

Tried compiling the latest bluetooth driver (from kernel.org) in conjunction with the kernel present in my computer did not resolve the problem. I am pretty much at wits end.

Tom (tom6) said : #6

Hi as this question is 5 days old now it might be worth re-posting the question to get some fresh eyes looking at it
https://answers.launchpad.net/ubuntu/+addquestion
I think Antony and i are stuck too.

Good luck and regards from
Tom :)

eddin (eddinw) said : #7

Ok, got a partial solution to the problem. The problem may have been caused by a bluez bug. This is what I did :
1) Downloaded the latest bluez source (bluez-4.50.tar.gz) from http://www.bluez.org/download/
2) Did the "./configure, make, sudo make install" routine.
3) Restart my computer. (Don't know if this step is necessary)
4) Attached bluetooth dongle, the bluetooth-applet did not appear. So I issued the command to reload the bluetooth driver, sudo /etc/init.d/bluetooth restart
5) Unattached bluetooth dongle and reattach. Voila bluetooth-applet appeared.
6) Issued the command: hcitool scan. Nothing happened. Repeat the command, and it scanned my bluetooth device.
7) Successful pairing with my device using the bluetooth-applet.

I think there must be some outstanding issues.
Firstly the bluetooth-applet did not appear the first time I attached the bluetooth dongle.
Secondly, the scan command has to be issued twice before.
Lastly, the message log (see below) still shows some time out error message.

[ 498.152213] usb 5-1: USB disconnect, address 4
[ 498.154235] btusb_intr_complete: hci0 urb f62ba280 failed to resubmit (19)
[ 498.154258] btusb_bulk_complete: hci0 urb f62bab00 failed to resubmit (19)
[ 498.155233] btusb_bulk_complete: hci0 urb f62ba900 failed to resubmit (19)
[ 498.159642] btusb_send_frame: hci0 urb f60e1b80 submission failed
[ 506.056135] usb 5-1: new full speed USB device using uhci_hcd and address 5
[ 506.243363] usb 5-1: configuration #1 chosen from 1 choice
[ 521.477798] hci_cmd_task: hci0 command tx timeout
[ 613.581770] input: Think Outside Keyboard as /devices/pci0000:00/0000:00:1d.3/usb5/5-1/5-1:1.0/bluetooth/hci0/hci0:6/input11
[ 613.592213] generic-bluetooth 0005:0A5C:2001.0004: input,hidraw3: BLUETOOTH HID v1.07 Keyboard [Think Outside Keyboard] on 00:10:60:B3:B9:8C

eddin (eddinw) said : #8

Crap, my bluetooth headset cannot function with bluez 4.5, although my bluetooth keyboard is working now. This is aggravating.

Tom (tom6) said : #9

Brilliant, nicely found and thanks for posting the answer back into here as we clearly needed to expand our knowledge-base a lot about this :)
Thanks and regards from
Tom :)

Tom (tom6) said : #10

Aaargh, two steps forwards and one step back?
Thanks for the update there tho :)
Good luck ;)