ATA TTRIM in Ubuntu 9.04

Asked by J

Are there any plans to patch the Ubuntu 9.04 kernel for ATA TRIM support?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux Edit question
Assignee:
No assignee Edit question
Solved by:
Steve
Solved:
Last query:
Last reply:
Revision history for this message
Robinson Tryon (colonelqubit) said :
#1

That's a great question.

I'm not sure how to set the source package for a Question, but this is something that the kernel package maintainers could answer -- if you can set the source package to 'linux', that might get you closer to an answer.

Revision history for this message
Best Steve (stupendoussteve-deactivatedaccount) said :
#2

This feature will most likely not be added to Jaunty. For stability, features are generally kept where they are. Big upgrades are left for the next release.

Please see this (short) thread: http://osdir.com/ml/linux-kernel/2009-05/msg02689.html

It appears it's a matter of timing to see if it makes it into Karmic.

Revision history for this message
J (dump) said :
#3

Thanks for the answers.

Guess I'll have to learn how to build, patch and package my own (Ubuntu) kernel then :(

This line probably describes my situation; You have hardware the stock Ubuntu kernel does not support.
https://help.ubuntu.com/community/Kernel/Compile

Revision history for this message
J (dump) said :
#4

Thanks Steven Susbauer, that solved my question.