No sound Ubuntu 20.04 Lenovo AIO A540

Asked by Horacio Merovich

I installed Ubuntu 20.04 in my Lenovo AIO A540 24ICB but the internal speakers doesn't work.

I get sound if I use external speakers connected to the audio jack or bluetooth spoeakers.

How can I solve the problem?

Best regards and thanks in advance

Horacio merovich

Question information

English Edit question
Ubuntu linux Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Manfred Hampl (m-hampl) said :
Revision history for this message
Horacio Merovich (hmerovich56) said :

I tried step1 and 2 without success

when I tried the step 3 I get some errors

horacio@horacio-IdeaCentre-AIO-5-24IMB05:~$ sudo apt update
[sudo] password for horacio:
Hit:1 focal InRelease
Hit:2 focal InRelease
Get:3 focal-updates InRelease [114 kB]
Ign:4 focal InRelease
Err:5 focal Release
  404 Not Found [IP: 80]
Get:6 focal-backports InRelease [101 kB]
Ign:7 focal-updates/main amd64 DEP-11 Metadata
Ign:8 focal-updates/universe amd64 DEP-11 Metadata
Ign:9 focal-updates/multiverse amd64 DEP-11 Metadata
Ign:10 focal-backports/universe amd64 DEP-11 Metadata
Get:7 focal-updates/main amd64 DEP-11 Metadata [282 kB]
Err:7 focal-updates/main amd64 DEP-11 Metadata
  File has unexpected size (282396 != 282456). Mirror sync in progress? [IP: 80]
  Hashes of expected file:
   - Filesize:282456 [weak]
   - SHA256:768f0d2888ecb75ed591ce633f91b16ced4591f4c1c3018713d9bb7fb5ab4fb4
   - SHA1:e6711d68b29cb05a570bfe7a7e018d97dc8b1f5d [weak]
   - MD5Sum:bb8819961c5c336dba0f039096c6ca9c [weak]
  Release file created at: Sat, 21 Aug 2021 23:03:52 +0000
Get:8 focal-updates/universe amd64 DEP-11 Metadata [351 kB]
Err:8 focal-updates/universe amd64 DEP-11 Metadata

Get:9 focal-updates/multiverse amd64 DEP-11 Metadata [940 B]
Err:9 focal-updates/multiverse amd64 DEP-11 Metadata

Get:10 focal-backports/universe amd64 DEP-11 Metadata [10,3 kB]
Err:10 focal-backports/universe amd64 DEP-11 Metadata
  Hash Sum mismatch
  Hashes of expected file:
   - Filesize:10324 [weak]
   - SHA256:e4c0bdca0abaad87267b2e4722f8f9521396e0985e4e07bd17e4caf0c6222795
   - SHA1:eb9d21b4cf4f25d3c352bedd8555b080c06b37b4 [weak]
   - MD5Sum:375aa9b7c5c57107bf676affc961a268 [weak]
  Hashes of received file:
   - SHA256:fa9aeb01ee8dc615bde46304e71849e9d2b73eb436be6ebecb2b8592e0f47a79
   - SHA1:4de41ea726edef8dc707a8d234bc12e28ef3302f [weak]
   - MD5Sum:e7e3c24c86181e42a6539f7d17cbcae5 [weak]
   - Filesize:10324 [weak]
  Last modification reported: Sat, 21 Aug 2021 19:19:50 +0000
  Release file created at: Sat, 21 Aug 2021 23:04:29 +0000
Hit:11 stable InRelease
Get:12 focal-security InRelease [114 kB]
Hit:13 stable InRelease
Reading package lists... Done
E: The repository ' focal Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Should I change this repository?
thanks for your help

Revision history for this message
Manfred Hampl (m-hampl) said :

I see two different issues:

1. The instruction to add ppa:ubuntu-audio-dev/alsa-daily is not valid for Ubuntu releases after bionic and you should remove that entry again:

sudo apt-add-repository --remove ppa:ubuntu-audio-dev/alsa-daily

2. There is a checksum error in the files that you download from the repository server. This can be caused by errors on the server, something going wrong on the network connection, or something on your system.

I suggest that you just try again now. If you still get similar error messages, I suggest that you try switching to a different repository server, e.g. or the central server.

Can you help with this problem?

Provide an answer of your own, or ask Horacio Merovich for more information if necessary.

To post a message you must log in.