int 14 error when trying to boot 9.04 (kernel 2.6.28) following upgrade or from install CD

Asked by Lance L on 2009-04-29

I've tried twice to upgrade to 9.04, and received the same error on the restart immediately after Grub selects kernel 2.6.28.11. After the first attempt, I reinstalled 8.10 from CD, which worked fine, and then tried the upgrade again. Today I burned a CD with 9.04 and attempted a clean install. The CD initially booted and passed an integrity check. When I clicked install, I immediately got the same error. Here is the error message:

BUG: Int 14: CR2 cl000000
          EDI cl000000 ESI 00000000 EBP c0731f50 ESP c0731f14
          EBX ff78f000 EDX 0000000e ECX 3fc04000 EAX 00000000
          err 00000002 EIP c073c30d CS 00000060 flg 00010016
Stack: ff78f000 ffffffff 00000001 00000002 00881000 00000000 ff78f000 ffffffff
          00000000 00000000 00000000 c0731fc4 c073ec52 00000000 c0731f76 00000004
          00000086 00000000 0000000f 000000a7 205b0000 30202020 c0731fd8

What does it mean?

The only GUESS I have is perhaps an incompatibility between the new linux kernel and the HighPoint IDE hard disk controller, which I have to run to use a newer 120GB HD on an old Compaq Presario 5868. But why would 8.10 and all the previous versions work with it and not 9.04?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu linux Edit question
Assignee:
No assignee Edit question
Last query:
2009-05-02
Last reply:
2009-05-11
Lance L (mrlechner) said : #1

Today I tried to run a Live CD version of Xubuntu 9.04. Inserting the CD brings up the menu. I get the same error if I choose to install here or even if I choose to run from CD with no changes to my system. Can't anybody shed some light on what is going on here? It appears to be a regression in the new kernel since the old kernel does not have this problem, so must be related to a recent change that was made.

Maybe this issue is similar to:
http://ubuntuforums.org/showthread.php?t=1136341

My system is currently having a similar problem (Bug: Int 14) on boot, though the install went easily. My current workaround is to hit 'ESC' when grub comes up and then selecting the 2.6.27 kernel. My issue seems to be the same as detailed in the thread that I mentioned so I'll be trying the clearing of the bios when I have time.

Good luck!

Hit the wrong button as it now seems as if this question is answered and it surely isn't! -- I should have hit 'Add Info Req' -- sorry. Not sure how to change the status back to 'not answered', but we'll see if this does it.

Can you help with this problem?

Provide an answer of your own, or ask Lance L for more information if necessary.

To post a message you must log in.