recently updated kernal to 5.3.0-53 from 5.3.0-51 but causes failure to shut down, seems to go through process, but Ethernet cable light and fan stay on, switch on next morning doesnt work untill a hard switch off (long press on power button) perfor

Asked by Peter on 2020-06-06

Since i recently updated kernel to 5.3.0-53 from 5.3.0-51 using linux Mint 19.3 i have had shut down issues and have had to revert to ver 51.
 System appears to shut down as normal but ethernet cable light stays on and the fan also. The following morning i have to use a hard power off before i can switch on again this happens with on screen graphics shutdown and with sudo shutdown -h now.
I am assuming it's to do with kernel change due to the timing of the start of the problem. But as this is a Ryzen 3 laptop also wonder if it could be the Ryzen bug... though i've not noticed any indication of that before. Is this a known problem?
(I realise this is an Ubuntu page, but was directed here by one of the Mint ones where i was trying to find an answer)
I do have the system set up to dual boot with windows, but that's worked fine and still does apart from an occasional clock offset issue. system mostly used for web browsing, Mail, Libre Office, Freciv, Wesnoth, occ Euler or Scilab, R, Inkscape....

System info

System: Host: peter-HP-Laptop-15-db0xxx Kernel: 5.3.0-51-generic x86_64 bits: 64 compiler: gcc
           v: 7.5.0 Desktop: Cinnamon 4.4.8 wm: muffin dm: LightDM Distro: Linux Mint 19.3 Tricia
           base: Ubuntu 18.04 bionic
Machine: Type: Laptop System: HP product: HP Laptop 15-db0xxx v: Type1ProductConfigId
           serial: <filter> Chassis: type: 10 serial: <filter>
           Mobo: HP model: 84AE v: 86.20 serial: <filter> UEFI: Insyde v: F.11 date: 08/20/2018
Battery: ID-1: BAT1 charge: 39.8 Wh condition: 39.5/41.9 Wh (94%) volts: 12.9/11.6
           model: Hewlett-Packard PABAS0241231 serial: <filter> status: Unknown
CPU: Topology: Dual Core model: AMD Ryzen 3 2200U with Radeon Vega Mobile Gfx bits: 64
           type: MT MCP arch: Zen L2 cache: 1024 KiB
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 19961
           Speed: 1382 MHz min/max: 1600/2500 MHz Core speeds (MHz): 1: 1319 2: 1366 3: 1430
           4: 1387
Graphics: Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series]
           vendor: Hewlett-Packard driver: amdgpu v: kernel bus ID: 04:00.0 chip ID: 1002:15dd
           Display: x11 server: X.Org 1.20.5 driver: amdgpu,ati unloaded: fbdev,modesetting,vesa
           resolution: 1920x1080~60Hz
           OpenGL: renderer: AMD RAVEN (DRM 3.33.0 5.3.0-51-generic LLVM 9.0.0) v: 4.5 Mesa 19.2.8
           direct render: Yes
Audio: Device-1: AMD vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 04:00.1
           chip ID: 1002:15de
           Device-2: AMD vendor: Hewlett-Packard driver: N/A bus ID: 04:00.5 chip ID: 1022:15e2
           Device-3: AMD vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 04:00.6
           chip ID: 1022:15e3
           Sound Server: ALSA v: k5.3.0-51-generic
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
           vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus ID: 02:00.0
           chip ID: 10ec:8168
           IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
           Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
           vendor: Hewlett-Packard driver: rtl8821ce v: v5.5.2.1_35598.20191029 port: 2000
           bus ID: 03:00.0 chip ID: 10ec:c821
           IF: wlo1 state: down mac: <filter>
Drives: Local Storage: total: 1.82 TiB used: 475.62 GiB (25.5%)
           ID-1: /dev/sda vendor: Seagate model: ST2000LM007-1R8174 size: 1.82 TiB speed: 6.0 Gb/s
           serial: <filter>
Partition: ID-1: / size: 109.50 GiB used: 30.11 GiB (27.5%) fs: ext4 dev: /dev/sda6
           ID-2: /home size: 473.55 GiB used: 445.44 GiB (94.1%) fs: ext4 dev: /dev/sda8
           ID-3: swap-1 size: 5.59 GiB used: 3.0 MiB (0.1%) fs: swap dev: /dev/sda7
Sensors: System Temperatures: cpu: 36.5 C mobo: N/A
           Fan Speeds (RPM): N/A
Repos: No active apt repos in: /etc/apt/sources.list
           Active apt repos in: /etc/apt/sources.list.d/gezakovacs-ppa-bionic.list
           1: deb http: //ppa.launchpad.net/gezakovacs/ppa/ubuntu bionic main
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
           1: deb http: //packages.linuxmint.com tricia main upstream import backport #id:linuxmint_main
           2: deb http: //archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
           3: deb http: //archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
           4: deb http: //archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
           5: deb http: //security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
           6: deb http: //archive.canonical.com/ubuntu/ bionic partner
Info: Processes: 210 Uptime: 44m Memory: 3.57 GiB used: 1.54 GiB (43.3%) Init: systemd v: 237
           runlevel: 5 Compilers: gcc: 7.5.0 alt: 7 Client: Unknown python3.6 client inxi: 3.0.32

Any Help would be appreciated as i always like to keep the system updated.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2020-06-06
Last query:
2020-06-06
Last reply:
2020-06-06

Linux Mint is not supported by the Ubuntu community or Canonical. Mint's support community is entirely separate from Ubuntu's. It has separate forms and support channels.

I suggest you post on the Mint forum here:
https://forums.linuxmint.com/

None of the "Ubuntu based" distributions are supported here. There are distribution agnostic forums on the Internet but this isn't one of them.

Peter (peter-lawrence-jones) said : #2

Thanks for the pointer, l will try there, i was a bit surprised to be directed to a Ubuntu page from the mint one i was looking in, but supposed that it might be because they built on your kernel base (... standing on the shoulders giants. etc) Again thanks for the help, hope this was not too great a distraction.
                                                                                 Peter

Peter (peter-lawrence-jones) said : #3

Thanks actionparsnip, that solved my question.

Peter (peter-lawrence-jones) said : #4

Sorry to add after 'solved' but thought i should put in the link i found on Mint forum in case anyone else lands here. Note Solved in the sense of not relevant to this forum, the issue appears as yet unsolved, related to ryzen cpu and kernel some how

https://forums.linuxmint.com/viewtopic.php?f=46&t=320149

https://bugs.launchpad.net/ubuntu/+source/linux-meta-hwe/+bug/1880041